Faulty Pan/Tilt Cameras

I bought 2 pan/tilt stick up cameras, both worked perfectly for 4 weeks until yesterday, now both will not let me change home position, calibrate or rotate cameras :cry:

I have the same problem, these have been working and all of a sudden over the past couple of days the pan/tilt has stopped working on the app

Hi neighbors! If your Pan/Tilt Mount isn’t responding or is failing to calibrate, please try the following troubleshooting steps:

  • Disconnect the Pan/Tilt Mount and power cycle your Camera by disconnecting it from power for at least 1 minute. Reconnect the Camera to power and reconnect the Pan/Tilt Mount.
  • Verify that there are no physical obstructions surrounding the camera that may be impacting the mount’s ability to function.
  • Verify the power cable is plugged into the mount and not the camera.

If this concern persists, please follow up with our support team at one of the numbers available here so they can look into this further. If you are outside of the US, please visit here to see how to contact support.

I’ve tried this.
I reset the cameras, reinstalled them and wasted hours testing different cameras with the pan/tilt. This was working and all of a sudden it no longer works

Nothing has changed this end but this does seem to relate to a recent app update

@user17826 If the suggested troubleshooting steps didn’t work, I’d just recommend following up with our support team for any further assistance on this concern. :slight_smile:

I have the same problem . . . There’s a whole other thread on the topic where it has been stated Ring is aware of the problem . . . yet you have one of their reps continually responding here to contact support . . . Is EVERYONE at Ring ever on the same page?

Same problem here. I’m not so sure anyone can be able to fix the issue over the phone. There must be something faulty with their 3rd gen pan/tilt mounts for the plug-in stick up cameras. Bought two pan/tilt mounts and cameras last week and the pan/tilt adjustments worked for a few days until my home had a power outage. After numerous attempts at resetting and following suggested setup procedures both of my cameras still will not allow me to calibrate a home position, aswell as allow pan/tilt adjustment through my RING app (although everything else seems to be working with the camera). I’ve tried using the Rapid Ring app a few times after reading another member here post about same issues, but this additional app makes no difference on my phone when trying to make pan/tilt adjustments. Will I need to send in both pan/tilt mounts in exchange for new ones like some have posted here? Thanks

This is clearly not something we have done, this is an update somewhere - ever on the app, camera pan/tilt or back end system which has broken the feature.

This isn’t the first time they have broken something

Hi neighbors! I checked with my team on this concern, and they are working on resolving it. Make sure your Ring app is fully updated and ensure you’re not trying to utilize the Pan/Tilt Mount in the Rapid Ring app. I’m marking this reply as the solution so other neighbors can see that our teams are working on this. Thank you for your feedback and patience in this matter!