Fails to shown the names of the locks

It seems that a bug was introduced in the app recently. After I click the Locks icon in the dashboard page, the names of the locks are not shown. But I can still lock and unlock them.

I talked to 3 different agents in Ring and they could not help. They also refused to report this problem to their internal development team to fix it.

Hi @daniesiu. What is the make and model number of the smart lock that you have linked? If it is not on the approved list of Works With Ring accessories, you may have limited function. The list of approved WWR accessories can be found here. :slightly_smiling_face:

I have the same issue. It worked perfectly up until last week sometime. Now when I click on “Locks” on the ring mobile dashboard they show the locks but no name is assigned it. When I click on that lock it takes me to another screen where the lock 's name is displayed. They definitely changed something. (I can still lock and unlock the locks I just don’t know which lock I am unlocking. ) Please fix this!!!

P.S. I just looked on the ring website and the lock that I purchased (Kwikset Smartcode 916) is no longer listed as a compatible lock. What the heck!!! It was on there when I purchased 4 of them.

Mine just started to do the same as well. And mine worked flawlessly up until that point.

Hey neighbors. Can you share which version of the Ring app you are using and what device type (phone model or tablet)? Additionally, what is the make and model of your Smart Lock? This will give me a better idea of what might be going on. :slightly_smiling_face:

Ring app version 3.37.0
Samsung S20
Android 11
Kwikset Z-Wave locks (not sure of the models)

Like the other posters mentioned, it is fine in the alarm tile. Locks show the correct name, status, and lock/unlock fine. It is only the Locks tile that has the issue.

If it works fine in one place and not the other, it wouldn’t be an issue with the device or compatibility. It is a software bug.

Bumping this thread, having the same issue on 3/30. I have 3 Yale YRD256 locks, on the approved list, that work just fine with the app and show the full functionality on the detail screen but appear without names on the Locks Tile. This appears to be a bug in the Locks Tile that does not show my chosen names for the locks and reduces the usability quite significantly.

Using Android 11 on a galaxy s10 with app version 3.37.0

Hey neighbors. Thank you for providing this information about your Ring app version and lock type. I’ve passed this information along to the appropriate team and this issue is being investigated. I will report back once I receive more information and I can provide a solution. Thank you for being patient while we resolve this for you! :slightly_smiling_face:

Hey neighbors. I wanted to provide an update for this concern regarding the names of locks not appearing in the Ring app under the Locks Shortcut. Please update your Ring app and ensure that your are running on the latest version. If you are running on the latest version and you are still experiencing this issue, reach out to our support team for the next best steps.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I have the latest app and am still having the issue. I will call customer support when I have time…

It is working now! Never had the chance to call support, started working on its own.

2 Likes