Error: Couldn't Load Your Locations

Having same issue. Working fine since installation on 24th, now all of a sudden aopnisnt working. Website is working. Just not app.

Same “Couldn’t load your location” error on my Google Pixel 7 Pro app ver 3.55.1. Works fine at Ring com but app is dead with no menus to choose from. Happened after I had to replace my defective Ring 2Pro doorbell this weekend. Now I can’t install my new Ring camera since I need the app to set it up. Looks like this is a running problem for Ring. Tech support acted like she has never heard of this and “escalated” my ticket. Expecting crickets while I wait for them to contact me. I’ll give it a week or 2 before I return it all in a bag to Amazon and cancel my Ring account.

UPDATE: I read another user reverted the new updated app to the previous version 3.54. I uninstalled the 3.55 app and searched online for ver 3.54. Quickly found it, installed and it’s working perfect again. This shows it’s a problem with the 3.55 version.

I was having the same issue as everybody here, started all of a sudden as far as I can tell. I tried all the troubleshooting steps discussed, nothing helped. Decided to try download and install version 3.54 of the app and it worked line a charm. Does not take much to figure out that the issue is with version 3.55.

Also having this issue with a Pixel 6 Pro. I have tried clearing app data, uninstalling, rebooting, with wifi enabled/disabled, etc… Nothing works. Even had my wife remove my account from the shared locations and then add me back. Website works fine on both phone and computer. Stopped working about 2 weeks ago. I also noticed I am still getting neighborhood notifications.

I did notice if I click on a notification it takes me to a different screen with “Add a Ring Product” and where at least the menu is there. The menu has “No Location” selected and that Dashboard is what fails. I can see Account Settings, Control Center, etc… Says version number is 3.55.1 in the menu.

having same issue. did a support chat earlier and got no help. why isn’t this an obvious issue to Ring support and a fix generated?!?

Running into the same issue on an Android phone- “Can’t find location”. Worked with Ring support for over an 1hr to determine issue. Works fine an an IPhone that I have for work. The rep finally admitted that there is a common issue with Android compatibility and a fix has been identified , but no ETA on when it will be published. In the meantime I have brand new equipment that is basically useless. This topic has not been solved and should not be listed on this site as solved.

Still same location error with ver. 3.55.1. As I mentioned earlier I found the previous version, 3.54.1, online and downloaded - uninstalled 3.55.1, and ran the old version. Works perfect. Problem is, phone keeps auto-updating to the new version. App stops working again. You need to go in and turn off Auto-Update through the Google Play Store settings or else it will keep updating to the new version and kill your app again.

1 Like

As of 1330 Hours on 11th January 2023, Rings highest level of tech support has started to work on this continued problem. My phone is on the Android op system- Galaxy s22. I am awaiting an email to hear what’s further needed but the hypothesis is that there is a bug hindering Connection in and to our app. This does not affect logging in through a website. I hope to hear back soon about any resolutions as I do get notifications but without opening the app I am unable to do much with my devices

I am having the same problem. Ring passed me off to AT&T which concluded it’t the ring app and a lot of other customers are having the same problem.

I am also have the connection issue error. I called tech support last week, and they also said that it is an Android phone issue. I cannot believe that Ring has been this unresponsive. They know that there is a problem yet they are just about silent on the cause and when the fix will be pushed out. This is really lousy customer service. Is anyone else wondering if Ring is going to refund us money for the lost time on the app?

Ok, it is January 24th, and its been 2 weeks now that I can’t use the RIng app on my Android phone because the app location error. When I spoke with Tech Support 2 weeks ago, they said that they know that the recent update wasn’t compatible with Android phones, and that they were working on it, and a fix would be out in 1 - 3 business days. Not even close. Ring doesn’t even reply now when I send them a Facebook PM to ask when I’ll be able to use the app again on my phone. What is wrong with the folks at Ring? Folks, version 3.55.1 is messed up. Why can’t you fix this?