Elvox 940A Audio Issue

I have tryed to install the intercom on an Elvox 940A system,
it was an intercom in wich all commands where sent over the bus , like (ring, opend door ecc…)
and the audio instead is trasmitted analog on another wire.

I know the intercom is not officially supported on the compatibility tool but the specific model is present on the app side so i will try to give a chance.

I think that for the work of engineer team is hard because the intercom on the market may vary and also are a lot.

So i connected using wire SET C
on wire for DIGIBUS (digital serial line)
on wire for audio IN/OUT (Analog)
on wire for the reference (Common Ground)

I was surprised because after the initial setup the app was able to recognize the signal of CALL for the specific intercom, the door command was issued correctly both if i ring from one or another door, switching all correctly.
I was impressed also because the tech documentation for the digital protocol is very hard to find.

The issue started with the audio the level was to high and there was a big feedback on external units (like lasern effect)
I’ve played a lot with the volume control but definitivly was to high and was unable to compensate.

I’ve tryed to contact customer care but after a quick chek they respond that the intercom is not supported and they didn’t know if was supported in future.

I’m an Engineer and nothing can stop to make trials, so i started to play and i’ve found that using a resistor on audio end was able to reduce the signal amplitude, unoftunatly this is not a realible solution because is only a part of the work, is also needed to balance between speech in and speech out (Mic and speaker on the app settings)

Unfortunatly the trimming is not possible with “call in progress”

So what i ask is a support because i think that the effort is not so big and the best is to have on the app the possibility to

  1. Reduce overall the Audio signal
  2. Make the ability to balance Mic and Speaker with call in progress (this because with trial and error is very difficult to do)

I think this can help to fully integrate the ring Intercom and maybe can be useful also for other types of intercom that have similar issue.

let me premise that I installed Intercom Ring on Thursday, May 4, 2023 and have since written to support because I can’t get it to test (in summary, it doesn’t work). My intercom is an Elvox 6204 (digiBus) apparently similar to the one you were able to configure. I connected the C cable, below is the wiring I did (as per the APP instructions):

  • pin1: C-9 (from the manual, it is the digital line for transmission/reception).
  • pin 3: C-2 (from the manual it is the voice and call line)
  • pin 4: C-10 (from the manual it is the ground)
    As soon as I make the call to my apartment, I get the following error code: P16-33-20032001 titled “Communication problems”. I did several tests with WiFi and saw that the Ring Intercom immediately enters the test mode when I press the button from the app (which is not connected to WiFi but to the mobile network).
    Comparing the manual I saw that my Elvox 6204 is similar to your Elvox 940A so I reconfigured App stating that I have a 940A: unfortunately nothing changes, I always get the above error code: P16-33-20032001.
    While waiting for Ring engineers to answer me, could you give me some advice ? (even some tests to do ?)

Thank you very much for everything

Have a nice day

verify first that the wiring pin number on the intercom pin 1 , 3 ,4 is referred to the number printed on the PCB (pratically are the first second and third screw on the terminal block)
then verify the correct connection to wifi of the ring intercom, disable the 5ghz network on your router this may help during setup and use form your phone 2.4ghz network to connect the phone and setup the ring.
I will also suggest to disconnect the pin 3 (C2) because the elettrical level are not right for the audio path.
then once the ring is connected to wifi router (not phone) you can launch the test mode, you have now to ring from entrance of your house to the intercom, ring intercept your call and start to test audio, at this point you cannot ear nothing just confirm all is ok.
once you arrived to this point i can suggest how to setup the audio, but his is a bit tricky so for this make sure digital comunication happen annd you can unlock door first.

I’ve just tried to configure Ring Intercom with Elvox 940A following the in app instructions.
Checked wired connection and Wifi connection.
When I try to make the test and I try to make the call to my apartment I get the P16-33-20032001 error (communication Problems).
My main purpose would be having the chance to open the door more than talking through the intercom. Do you have a suggestion that I could try to make it work?
Thanx in advance

ok, if you have completed at least the first part for the connection to wifi i think you are able so see in your router the ring intercom connected.
anyway, if you open the app and go to devices you may see the device online.
tap on the device and go to device status, here you see the device is conected the signal is ok ?
and on last control time is reported a date at least of today ?
if all is ok try to repeat the same procedure but this time with your phone disconnected from wifi, in this case you have to see the device online and all the data you see when is connected.
then keep the wifi of phone off and repeat the procedure to complete configuration, there is the possibility that if you start the configuration at home when you go to the main entrace you drop the wifi and is not able to roam correct on the cellular line causing the drop of connection.

Hi, first of all, thank you for the suggestions.
Pins 1,3,4,5 are in sequence.
My intercom ring is connected to WiFi properly: I can see it by going to device and status; as proof of proper operation I leave the phone connected only to the data connection and as soon as I activate the test mode on the ring the flashing green circle comes on.
That said I followed your advice and disconnected C2 from pin 3 and tried the test procedure again. Unfortunately, the result is still that damn error code: P16-33-20032001. As a layman it is as if the ring does not even hear the call.
Do you have any suggestions ?
Yesterday after 9 days “Aya from SC Ring” wrote to me giving me the link of a workdocs and telling me to follow the steps therein, too bad I cannot access the link as I am not an Amazon employee !

Thanks again

Have a nice day


1 Like

I just tried and the result is the same as Lorenzo.

  • Disconnected Pin C2 from pin 3.
  • Wifi connection to the device is ok. It can be seen online via wifi and via cellular line.
  • Disabled WiFi. Started the test (green light blinks as expected)
  • At the main entrance I make the call but nothing happens (as Lorenzo said, the Ring does not receive the call)
  • Then the damned error code P16-33-20032001
    Please let me know if you will receive a valid feedback by Ring’s assistance, I will do the same :slightly_smiling_face:


Have a nice day

1 Like

I have make a search and seems that the error P16-33-20032001 is related to the ring intercom missing the call to be identified.
i see this error appears on different model/brand.
you can try to reset and repeat all the process and check that the wires properly connect on the terminal , otherwise may be related to the impossibility to read the code for example for a digital line excessivly disturbed.
Additionally for the Elvox 940A keep in mind that it is a 4 digit coded the **Elvox 6204 can instead work on 4 digit coded and 8 digit coded and this depend by the system configuration.
can you post a photo of the wiring of the intercom ?
In the meanwhile i’ve resolved for the audio part but i’m doing some test.
It was helpful if someone can put in comunication with the engineering team to have a second level support.

1 Like

Hi, thanks for the additional thoughts you added in the post.
The fact that the error means that it can’t “hear” the call, I’d say that’s in line with what’s happening (I press the intercom and nothing appears on the ring, when I press on the APP that I made the call I get that error in a second).

Keep in mind that I tried only once to set the ring to use Elvox 904A, then I always re-set it to 6204. The contacts are firm, fortunately the normal intercom continues to work.

My intercom line is not disturbed at all, even with the ring connected the call is clear and everything works as usual.

Just to give you an idea of my system: 6 buildings totaling about 250 intercoms + 1 “plate” outside the apartment building + 6 “plates” on each building + 1 call/reception system from the janitor. If no one calls me and I press the key (to open the door), a call to the janitor starts. When they call me instead, with the button I open a gate (outside the apartment building if the call comes from there, of the building if the person calls me from under the building).

The doubt I have is that the ring can’t hear the binary code coming in on my wire, maybe it can’t synchronize or so many 0’s and 1’s are coming in and my ring can’t intercept mine. It would be nice to be able to put it in debug mode, it would be interesting to see what comes in on those pins when I press the button and when I don’t press the button (I guess that’s what the Ring people could do, but they will have thousands of open issues they can’t handle !)

I have attached only one photo of Ring’s connection to the intercom, as the forum would not allow me to attach more.

I have contacted customer service and they are writing to me (two weeks later) in a spotty and slow manner and so far have not said anything helpful !
The last message I received from support was on Saturday, May 13, in which a certain “Aya from SC Ring” turned a link to me with instructions to follow. Too bad the instructions are on Amazon’s intranet and only employees can access them ! I immediately replied that I could not access, and at the moment no other “engineer” has shown up !

Thank you very much for all the advice you are giving us.

Have a great day

Hi, here attached is my 940A with the three wires firmly connected.
My building setup is exactly the same as described by Lorenzo. Same for the app behaviour.
I’ve sent pictures to the Ring’s assistance … let’s see what they will reply.

Thanx for all advices :slight_smile:

Have a nice day

the wirng is correct, the suspect is that for some reason it cannot detect the code when ring from external plate, i doubth that there is data traffic when the system is in standby.
when a call is make from external plate first all intercom reset because the supply is cut (in this way is avoided that any intercom can be in call mode and in this way is resetted) then the code is trasmitted to all intercom and only the called one was able to inserted in the phonic line (led on and click from relay onboard of intercom pcb.
One thing to try is to measure with a multimeter between pin 4 and pin 5 (this is the supply of the intercom) if the voltage is near 13.5 V and the voltage between pin 4 and 1 is about 11-12V we are sure that also the digital line pin 1 on wich the digibus signat travel maybe have the correct levels.
there are also another possibility but i have to investigate we can try to set the ring intercom as generic one (Elvox 902) and use the output pin 6 of terminal block that normally stay at supply level and goes to 0 V when a call is inserted (is used for supplementary ring)
then wire directly on opening button to issue the opening command .

in this case you bypass completly the digital detection and leave the original intercom to generate a signal from supply to GND used to detect the call in this case you have to use cable A

A1 – > pin 4 (GND 0V)
A6 → pin 6 (Call sensing voltage)
A4 and A5 → to two termial of opening button (on 940A for sure on 6204 i don’t know if there are a wired opening pushbutton)

for sure if the app will give the possibility to go in debug mode this can help to resolve the issue but i think this is not in the style of the vendor.

tried configuring as per your suggestion ( configuring it as Elvox 902 and using cable A).
Put it in test mode, gone to the entrance pressed the call button. The app says the Ring Intercom does not receive the call (after a long time it waits for it).

Still waiting for a reply from the engineering team :slight_smile:

I will keep you updated

1 Like

first of all, I apologize for the late response, thank you both for looking for new solutions/ideas.

On Wednesday, May 17, I was emailed, "Our technicians have updated your device. Please try the test again.

I swear to you, I thought they had really solved it this time or at least we had taken a step forward !
Instead as soon as I tried, almost instantly I got the error, which this time changed code :D: “p16-33-422”. I have the impression that I am a beta tester who instead of being paid for testing, had to pay for an unripe product and by the way, waits for days for testing without getting feedback from a real engineer, but getting fake answers from the operator on duty !
I’m really disappointed in Ring’s customer service, I understand that they have so many reports (not a good sign for them, except of course to the sales success, for the promo price last month) but customers don’t treat each other like this, I see it as disrespect !

I replied to that email, thanking them and saying that the error had changed and if they would send me instructions in a different way than a link on AWS. The response was an apology for the operator who had sent me the link, saying he made a mistake… I would have loved to see a shred of a test document to follow, but nothing they prefer to reply to you once a week saying to try again with the same results…

Sorry for the outburst (I already know that no one from the help desk will read this complaint of mine, finally stepping in to solve the problem like real engineers), if you have any other ideas I am there :).

Thanks again for everything

Have a great day

Yesterday they finally wrote me from support to try again with a new firmware-.

Amazing news, everything works. I’ve been trying and trying again for two days and everything works properly.

Thank you for your support and the Ring team

Have a great day


so finally also your works, sincerly i didn’t undarstand how the deployment of new firmware are managed.
The Audio part is funtional ?
in my setup i’ve make a little pcb with some components to adapt the audio signal.
In your intercom setup how about the audio ?

In your case do you have update from Ring Team, because the protcol is the same of Lorenzo there are no reson they didn’t work


Hi, 5 days ago the assistance asked me to fill a yes no survey.
They told me 940A is not yet supported but anyways present in the app for test purposes.
In any case they promised to assist me and provide me with further info. Still waiting :slight_smile:
Today I saw the Ring Intercom blinking light blue and then blue. I don 't know if they are making some tests or updates from remote.
@TheLawOfLorentz which version of firmware do you have?


Hi, a little update.
Assistance wrote they made an update and asked me to make the test.
I did it and now the Ring intercom catches the call and gives me the possibility to open the door.
But if I try to answer the call, at the doorbell panel a strong whistle covers all communication. Nothing can be heard (whistle apart) neither at the panel nor the app.

Hope they will fix it

Have a nice day

Hi, thanks for your interest.
Everything works for me, both voice and calling from two external intercoms and opening two gates (it happens with the same button, depending on where you are called).
The only note is that you have to yell for a moment to be heard from both the smartphone and the intercom.
Have a nice day

@Dalidah asked me for the firmware version which I don’t see…
If I click on “Device status” I see: battery level, WiFi signal strength, Network name, Ring name, MAC address, Intercom type (FDX digital), Firmware (Up to date)…

I’m sorry, if you tell me recover it I will try.

Have a nice day


@TheLawOfLorentz, how did you set volume levels?

Thanx a lot