Echo Show 8 mic not working

Sorry to hear about this concern persisting, neighbors! If you have not already tried, please ensure the microphone is toggled on your Echo device screen. You will see in our help center article, there are a few commands that will initiate two way audio. Check out the tips there to see if they work for you.

If none of those methods or troubleshooting steps work, try removing and re-adding the Ring skill to the Amazon device/ app. Please also ensure that your Alexa device is within range of your router’s wifi signal. Additionally, try out the two way audio on different event types, such as live view, motions, and/ or Video Doorbell rings. Feel free to let us know how this goes! :slight_smile:

Hi
I have tried all your suggestions and still no luck.

When i try speaking through my mobile it works fine - so this looks to be an issue with the software of the amazon echo device.

I have factory reset the devices and removed the skill and re-added but the same issue occurs
Looking at forums this is an issue for quite a few people

Nothing works, I’ve tried everything you suggested already. We are ALL having the same issue, it can’t be on our end. If I ask alexa to show me the front door, then I can activate/deactivate the mic from the echo and everything works just fine. However when someone rings the doorbell or motion is detected and the video feed is automatically displayed, pressing the mic icon will do absolutely nothing and you won’t be able to talk to whoever is at the doorbell. It’s been going on for more than a month, before that it was working just fine. It’s clearly some kind of bug in the alexa skill, fireOS or in the firmware/ring backend. I have no idea, but it needs immediate fixing. PLEASE, the only thing you can do for us is to report this bug to whoever can actually do something about it. My localized version of the ring app is full of one star reviews all stating this exact same issue we are all having. I hope they are aware and working on it. If not, if you have any way to do it, PLEASE report it to someone who can take care of this asap. It’s the only thing you can do for us that could actually be helpful

Hello, reporting from Mexico. I’m having the same issue as others, trust me that we have already tried all the possible troubleshooting available and this won’t be solved by sending us replacement devices (Echos and doorbells) because this is a software issue, either in the Alexa Ring skill or the Echo OS. I will just mention again the symptoms:

When someone rings, in the Echo Show the live video shows up, when taping to unmute the mic and start talking, the person at the door won’t hear anything, I have even tried myself and have members of my family help with the testing. This doesn’t happen when answering from a mobile device (iPhone).

It seems that if you ask Alexa to show, for example, the main entrance, and replicate the same to unmute and talk, it works! So definitely there is something wrong.

Please work with Amazon or Ring but fix this!

1 Like

Just bought the wired ring. If i talk through my phone . Outside speaker is working and i can also listen to the person outside .

But through alexa i can hear the person outside but they cannot hear me when door bell is rang. I was also pressing mute unmute button on alexa show.

Let me know if someone figures this out

1 Like

Out of curiosity guys, do you have more than 1 echo show device aka more than 1 echo device with a display? I have two (one echo show 5 and one echo show 8), I would like to know if there is someone that has this bug and has only 1 echo device with a display. I feel like having multiple display devices only added complexity with my doorbell. I also have to say that everything worked fine for a while despite me having 2 echo devices, so it might be irrelevant for this bug. All I know is that both the app, the ring skill and the devices themselves have way too many bugs for how big of a company ring is now.

I have the same Echo devices (5 and 8). As far as I recall, the issue never happened with the 5, which was the first I got. Might be worth it to test by only having one active, but of course this would need to be fixed by either Amazon or Ring.

2 Likes

The same issue in New Zealand.

I own one show 8 and 3 echo dots
As the latest feed suggested, I deactivated 3 dots for doorbell to see whether this setup works.

Long story short, this setup failed.
Microphone only works with live view feed.

Please fix this.

1 Like

I am also seeing this issue in Mexico with my Echo show 5 and Ring doorbell 2. Please let us know when this issue is resolved.

Same issue in the USA as our users in Germany, Italy and so on, so perhaps it’s not a localization issue but a core skill issue. It’s hard to believe that this issue is not being addressed by the development team! What’s the process for escalating this critical bug?

Exact same issue as Raekon.

Mic works on my Echo Show in live view but not when someone presses the door bell!

Same issue here with an Echo Show 5. If I manually access the front door from the Echo Show, I can tap the mic and the visitor can hear. If a visitor rings the doorbell, and I tap the mic, they cannot hear me. I did notice that the blue ring on the doorbell continues to swirl even after tapping the mic on the Echo Show to enable it, so it seems like tapping the mic does not answer the doorbell ring. This is why the visitor cannot hear.

This is obviously a software issue, and not a hardware problem since the mic works fine when accessing the camera directly. I’m in the USA, so I think this problem is global. I just got my Ring as part of the great pre-Prime Day deal for an Echo Dot and Ring for $45. I suspect more and more users that also signed up for this deal and have Echo Shows are going to experience the same problem.

Follow-up to my prior post. So after having someone ring, I answered the door via the phone app. The blue ring then stops swirling (of course, as designed). Then at that point, tapping the mic on the Echo Show does allow two-way communication to work from the Echo Show. The Echo Show app needs to answer automatically when you tap the mic when someone rings the doorbell. As I stated before, this is obviously a software problem.

Sorry to see this concern is persisting for some neighbors. If you’ve already tried the steps mentioned in my previous responses above, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Thank you! :slight_smile:

I am having this same issue. It’s something to do with the software it seems. The solution identified in this thread does not appear to be the actual solution.

Testing
• If the Echo Show is set up as an announcement device AND when doorbell is actively in a “post-press” mode (meaning, someone has pressed the button and the blue light swirls around the button), cannot connect to doorbell from Echo Show. Two-way communication doesn’t work at all and goes back to the home screen.
• If the Echo Show is NOT set up as an announcement device AND when doorbell is actively in a “post-press” mode (meaning, someone has pressed the button and the blue light swirls around the button), the Echo show can see the live video and hear the person, but the person cannot hear you.
• Only after the swirl stops moving and/or the button has not been pressed can you “answer the door” and two-way communications works as intended (voice and video works in both directions).

WORKAROUND
Best case scenario is to not use the Echo Show as an announcement device. Even though the person at the door can’t hear you, at least you can tell Alexa “Answer Front Door” to see who’s at the door when they press the button and then you can choose to get up and answer the door or not. Must have another working chime for this to be effective.

Glad I found this thread. There doesn’t seem to be anywhere else talking about this problem. I guess most people use their phone to answer the door. We have elderly people who don’t have a smart phone, so the Echo Show is the only way they can do this (and it’s the primary reason why we got this).

Hope this gets fixed soon!

1 Like