Echo show 5 will not show ring doorbell gen 2

We’re having issues with one of our echo devices being able to connect to our gen 2 doorbell.

We have 4 echo devices (original echo, echo show 10, echo dot, and echo show 5, and all of them can connect, except my father’s echo show 5. When asking the show 5 to show the door, it comes up with ‘waiting for ring.com’ for a few seconds, then goes back to the home screen.

I’ve tried rebooting everything (all the echo’s, the doorbell, and the router (a draytek vigor 2762ac)), but it has made no difference. The signal strength for the doorbell is 59, which is good according to the ring app, so it’s unlikely to be a signal issue.

Announcements weren’t working earlier until I rebooted everything, but are now working, but the echo show 5 still gives up trying to connect to the doorbell after a few seconds.

Hi @csc2ya. Those were excellent steps to take to address your concern. I would also recommend disabling and reenabling the Ring Skill in your Alexa app. This Help Center article will provide you with the steps to do so. If you have tried this step and are still having the same concern, give our support team a call for further assistance.