Echo Show 5 not recognizing my Ring doorbell

My wife purchased a battery operated Ring doorbell (2nd generation), along with an Echo Show 5. For whatever reason, the Echo device does not recognize the doorbell whatsoever. I have done the following:

  1. Doorbell is showing on my Ring app, and I am able to see video and hear audio, and am able to communicate to the person outside.

  2. Ring has been added as a skill on Alexa app. Have tried removing and re-adding the skill.

  3. Doorbell press notifications are on.

  4. Echo Show 5 has been selected as a notification device, and does chime when the doorbell button is pressed.

I have removed and re-added the Ring skill, and removed and re-added the cameras multiple times. When the doorbell is pressed, the notification gets sent to the Echo Show, but when I tell Alexa to answer or show the Front door, it keeps saying the device is not found.

Hi @BPT1976. You have tried all the basic troubleshooting steps I would have recommended for this type of concern. The next best step is to contact our support team for further assistance. Give our support team a call at one of the numbers available here