Echo Dot 4 & Echo Show 10 Internal Bridge/Alexa Skill Trouble

I purchased a Ring Mailbox Sensor that is supposed to work with the bridges built in to the Echo Dot 4 and the Echo Show 10. Whenever I go through the process of setting this up through the Ring app, it tells me that I must set up the Ring skill. The skill has been set up for a long time, but I disabled and enabled several times, and it has not helped. Is there something wrong with this skill?

I’m attempting the same thing and have the same results. Anyone been able to make this work?

Hi there, neighbors! This sounds similar to this Community thread, which there are some steps shared there that might work for you.

If you have another mobile device, try performing this setup on another device. Check out our help center article for helpful tips and steps on using your Echo show as a Bridge.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

The builtin bridge is only for echo 4 not dot versions? Or is it both regular and dot 4? The link I was given last time says echo 4 not dot 4.

Hi @KJSS. Correct. The Ring Bridge is only available in the Echo and Echo Show, not the Echo Dot.

Dot 4 is too small to have a bridge inside. Because I got good deal on a dot 4.