Doorbell Wired Installation problem UK

I am installing a doorbell wired in the UK. I am powering direct from a Ring power adapter via the old bell wiring, I am getting 24VDC at the ring unit. I never get to the spinning white light - I just get a flashing blue light pulsing every second or so. I have tried the reset button, makes no difference.

If I put the power source direct onto the bell it just goes a solid blue and reset button has no impact.

Totally lost, please help!

Update - we have rewired so that doorbell is now powered directly by Ring plug adapter - now have solid blue light and unable to add as a device via app - please help!

Hi @user72896. When you press the setup button on the side of your Doorbell, is it entering set-up mode? It should spin white and say that it is in set-up mode.

I’m having this same issue, we’ve been wired to the mains for 24 hours, the blue ring is showing, but regardless of how long I hold down the orange button I can’t get the spinning white light. I’ve completed all steps requested by the RING App to this point. Any help would be appreciated.

Hi @user74195. If your Doorbell is not entering setup mode and you have already tried a reset, give our support team a call for further assistance.