Disabling Ring Doorbell 2 announcements on selected Echo devices doesn't seem to work


In the Alexa App, I go to Settings->Device Settings->select the name assigned to the Ring doorbell (“Front Door”)->Announcement Devices. I’ve unselected two of the Echos – a 1st Generation Echo and a 1st Generation Echo Dot.

The problem is that even though both of these are unselected, I still get Ring announcements (e.g., motion detected) on both of them.

I’ve tried disabling the Ring skill, re-enabling and re-linking to my Ring account but it doesn’t seem to make a difference.

What do I do?

Hey @Chapter11Ferengi. Could you try uninstalling the Amazon Alexa app, rebooting your phone and reinstalling it to see if this helps? In addition, do you only have the two Echo devices? If so, you can turn off motion announcements and/or doorbell press announcements from the Ring device’s profile page in the Amazon Alexa app, as this will disable all motion alerts for all echo devices connected. Let me know how this goes! :slight_smile:

Hi Chelsea,

To answer your other question, yes I do have other Echos and those are selected to do the Announcements (those work fine).

I carefully followed the steps – uninstall Alexa App, reboot, reinstall. When I launch the app and go into Announcements again, it still shows the two Echos as unselected. Was the uninstall/reboot/reinstall supposed to change them to be selected? I haven’t made any changes yet so I’ll await your next suggestion.

@Chapter11Ferengi Thanks so much for getting back to me on this concern and clearing up what kind of devices we’re working with in total. The uninstall/reboot/reinstall normally helps ensure the app is the most up to date in order to save the changes in full that you’re making. If they showed as selected, that would mean the changes weren’t saving before, but it looks like they were!

Do you mind reaching out to our support team for further assistance on this concern? It seems they may need to look more into how your RIng devices are operating to ensure they are following the same settings as Alexa. They will ensure if this seems to be a Ring or Alexa side of things, so please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes! :slight_smile:


The issue hasn’t been resolved but I wanted to post an update.

I spoke with a member of the support team and was very impressed with her level of knowledge and professionalism.

  1. You wrote, “It seems they may need to look more into how your RIng devices are operating to ensure they are following the same settings as Alexa.” I sent a screen capture of your complete reply to the woman I spoke to and she said there is no way they can verify Ring devices “are following the same settings as Alexa.” She could not explain what you might have meant, only that this is beyond Ring support’s capability. At the very least, it seems misleading to me.

  2. She suggested I contact Amazon as the issue appears to be on their side. I have three-way calling and I offered to get her and Amazon support on the phone at the same time but she said that is against company policy. When I asked why, and what the problem is with doing so, she could not explain and just kept saying it was against company policy. I’m in the middle here, and both Ring and Amazon really need to talk together, and to me it makes perfect sense and seems like a logical and reasonable request. Can you explain why this is against company policy? I would like to understand.

  3. I worked with an Amazon tech support representative so they could carefully document the issue and send a support ticket to their engineer/development team. It is my understanding it could take about a week to hear back from them.