Different Language

So out of nowhere my language is different in the doorbell. I initially set it up in English now it’s sending alerts in Spanish. Has anyone experienced this before? And if so how did you change in back to the original language.

1 Like

Same here - I’m suddenly getting alerts in German. My wife’s iPhone language is set to German and she has the ring app monitoring the same devices as me but is logged in with her account. Very strange. I’ve tried reinstalling the app but it’s still doing it. Looks like a bug to me.

1 Like

Same here, getting iphone alerts in German and can’t seem to find any settings to change it back. Might have coincided with an iOS release.

Hey Neighbors! The first thing to check here would be the language settings on your mobile device. Please ensure these are set to the desired language, and that your other apps are also notifying in your desired language.

If this concern persists, please uninstall the app, power off your mobile device, power on your mobile device, and reinstall the Ring app. Let us know how this goes! :slight_smile:

I have gone through all of these steps and the issue has not been corrected. There is only one language selected for use on my iphone, just english and no other apps are displaying in another language (notifications or otherwise).

Per your suggestion, I also uninstalled, restarted the phone and then reinstalled the app to no avail either.

I’ve attached screenshots of the notification, as well as from the app itself so that you can see only the notification displays in German.

I’ve gone through these steps as well and it’s still happening on both my iphone and ipad which are both on iOS/iPadOS 13.1.3. I think it’s only started since the iOS upgrade.

Thank you for this information! We have sent it to the team to review and will be in touch with more information once available.

I am having the same issue, i.e. Spanish notification while the app and ios are set toe English.

Delete and reinstall did not resolve the issue.

Thanks

Did anyone ever get a reply about fix? Thanks.

I’m having the same issue. All of our alerts are now in German even though my language in the app and language used online is English. I’m assuming it’s because our address in the system is German. I can’t find out where to change the language back to English.

Hey neighbors! Our Ring app can support a few different languages out there. If you have the language on your phone changed (or recently changed) from another language to English, you will need to ensure that you log out and log back into the Ring app in order for the push notifications to be translated to the language you have updated it to. The Ring app is designed to take off from the language on your phone’s settings, not in the app. If you have found that you have tried this troubleshooting step, please then try to remove the Ring app from your phone, reboot your phone and then reinstall the app. After reinstalling, ensure you are getting notifications in the language you desire. You can also try changing from the other language and then back to English before re-downloading the app, but before the reboot of your phone.

In the event that you may not find notifications in the proper language, please take a screenshot of the notification in the wrong language, and then a screenshot of your phone’s settings set to the language you desire. From there we can take this information and escalate it up to the appropriate teams to have this looked into further. Let me know also the phone you have or the device you are using it on, and the iOS/OS for that phone. :slight_smile:

I have never changed my phone app settings to any language other than English. My push notifications in my iPhone displays in English. It’s only my emails that I recieve that show up in German. I deleted the app on my phone and reinstalled it and I keep getting email notifications in German.

@thomasd04 My apologizes, I thought you were talking about the push notification to your phone being in German, not the email notification. Can you take a screenshot of this email notification so I can be certain I know what you are referencing that is showing in the wrong language? Thank you in advance, neighbor! :slight_smile:

I’ve attached a screenshot of a recent email. The emails changed suddently on 6 May and continues today.

who in the right mind does this? the app checks the phone for the language? why? I want my apps to be in a language that I want… my phone is in English some apps are in Portuguese some are in Spanish some are in French… we dont have any iPhone’s in the house NEVER WILL we use android and there is still no setting to change the language… do you need any help on programming a button to change the variables to translate the app in another language??? please have a simple button to change the language it is BAD REALLY BAD not having this option like unacceptable BAD… and the user UI and then the notification comes I have to scroll down and then tap the notification to open the app? please hire someone to fix this thank you

2 Likes

what the f.
I could not set up a chime and the tech asked me to re install the app now everything is in German…why?
As mention in a post before make the choice of language in the settings.
What do I do now?

I’ve never had this issue myself. I have many Android phones as well. Are you up to date with the Ring app? I’m guessing you already checked your language and location settings on your phone. The only thing I can think of is possibly you don’t have the location permission on for the Ring app… What make and model of Android phone are you using. I might have it to troubleshoot it.

1 Like

The problem I’m having is with the emails, not the mobile app. My emails started showing up in German instead of English. However, a month ago they started showing up in both German and English in the same email. So my problem is solved (although it would just make more sense to allow customers to choose what language they want the emails).