Device says battery low but is fully charged

I’ve just changed the battery for a fully charged one but my app is still saying it is low at 26%. I’ve tried removing/replacing the battery, deleting the app and setting up the doorbell as a new device but nothing has worked! Please help!

I’m having the exact same problem. Live view is disabled as a result.

Hey neighbors! Thank you for helping each other out in this thread as we experience some outages with the Ring app and Please note that the issues within the app and the website would have been affecting this feature, but as of Nov 27, 11:44 UTC, a fix has been implemented and we are monitoring the results. If you are still experiencing any further issues with your Ring devices and how they were behaving previously, I recommend giving our support team a call so they can look into this further. You can give our support team a call at one of the numbers available here. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.