Device Health says Ring solar charger not connected... but it is

Ever since the big Ring outage last week my iPhone and iPad apps says Solar Status is ‘Not Connected’. It is connected and always has been. The fact that the battery level has been quite constant is probably the best indicator. Anyone else got this problem, and is there a fix? Thanks in advance.

Mine has been working fine previously, but in the last couple of weeks just displays “not connected” all the time. I didn’t have an issue when it was reading “Not established”, because sunlight had been limited, so wasn’t charging and battery depleting, but now it’s always not connected.
Have taken it off and resecured the connections, but still the same.
Seems to be an issue for many having googled it.

Hi neighbours. I can offer a suggestion you may not have tried. With your Solar Panel securely connected, reset you camera. You can do this by pressing and holding the setup button for 20 seconds, then release. You camera will take around 1 minute to reboot, then you can reconnect it to wifi. Your camera will perform an update and over the course of the next few days, you should see your connection change to display the proper status. I hope this helps!

Where is the reset button and when you do this will you have to set up this camera again then ? I have had the same problem since the outage. My solar panel won’t charge and when it does it barely charges. Only had charger for less then 6 months. Most time it keeps telling me no solar charger connected

1 Like

Hi there, @williams1276. The reset button for your Ring device is the same as the setup button. Holding the setup button for 20 seconds will result in a reset. As we enter the season for cold and overcast weather, please keep in mind that several hours of sunlight per day is crucial for the Solar Charger to provide a proper connection. I hope this helps! :slight_smile:

I have been struggling with the same issue for several days. I removed the battery , made certain it was at 100% charge, then went back through the setup procedures. Same result, not showing the the solar panel connection? Unit has been back in place for over 24 hours with no change? Camera is working, solar panel NO WAY! I’m on the verge of just boxing everything up & returning it! From the posts I’ve read this seems to be a common issue. WHY! Shouldn’t this be a more user friendly process or am I missing something??

Still having the same issue.
Bought it in August. Worked for the first month or so and since then, Not Connected for months, which is different to what I saw displayed when there was just not enough sunlight.
Have reset the camera, removed and reattached the connections. Nothing resolves it.
Come on, Ring! Acknowledge this as an issue as it’s affecting many people.