Decryption Error with End to End Encrypted Cameras

Over the last 36 hours, I have been experiencing a decryption error when attempting to view all motion events under Event History on my end to end encrypted (advanced encryption) cameras. Motion is recorded, and I even receive a motion alert. However, when I go to view the motion under Event History, the videos load for a while, but never play. Eventually, after loading for a while, I receive a playback decryption error. This decryption error occurs on all 3 of my end to end encrypted cameras, but not on my non-advanced encryption cameras. This decryption error occurs on all my devices, too (both IOS and Android). I’ve attempted to delete the Ring app, and reinstall, however, this resolved nothing. Everything is up to date, including the camera firmware and the Ring apps on my devices. My subscription is current and my wifi network hasn’t changed. Live view works perfectly fine. The error is exclusively related to playback on the Event History Timeline. It’s odd because the end to end encrypted cameras have worked perfectly for 6 months before today. Any ideas what is going on? Was a new camera firmware rolled out a few days ago? Thanks.


Hi @user38894. Thank you for trying to troubleshoot your concern. You can try rebooting your Cameras using the Ring app. You can also try rebooting your router by unplugging it for a few seconds and plugging it back in. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here to further investigate. If you are outside of the US, please visit here to see how to contact support.

user38894 -

I am also unable to view E2EE videos that were created as a result of motion detection. This is obviously a very serious problem.

Interestingly, I am able to view E2EE videos that were created as a result of the Live View feature.

1 Like

Ring Community Members -

If you use Ring’s End-to-End Encryption (E2EE) feature for one or more Ring devices… are you able to view videos that were created due to motion detection? (In other words, I’m trying to determine if this problem affects all users that use the E2EE feature.)

1 Like

@Frustrated427 I have done further testing since my last post. I can almost assure that the issue is on Rings end. I’ve put my cameras on LTE hotspots, and the issue still persists, where I cannot view motion recordings in event history. As you previously said, I can indeed view live view events. Putting the cameras on this new network further proves that the issue is not based on the home network.

My confidence in the issue being on rings end stems from 6 days of testing:

Connecting cameras to a new network (an LTE hotspot, mentioned above). I’ve unenrolled my account from end to end encryption, and re-enrolled (creating a new seed code), and the issue still persists. I’ve factory reset all my cameras, and the issue still persists. I’ve unenrolled and re-enrolled my cameras from E2EE and still nothing. I’ve unenrolled and re-enrolled my devices (and still cannot view motion events). I’ve cycled between android and iOS devices. Nothing works. At this point, I have run out of things to test, leading me to believe the issue is from a bad firmware update.

As I’ve previously mentioned, I wonder if they put out a device firmware update that is causing a decryption issue on their end. Because, I can say with a high degree of confidence that the issue is not on my side.

I think this is infrequently reported on because most users don’t use the E2EE features.

Please let me know if you find anything else out.

1 Like

user38894 -

Thank you for taking the time to perform the experiments as well as to post your results here.

Actually, I’m not surprised at your results. Unfortunately, this is not the first time decryption problems have occurred with Ring’s E2EE feature. Sadly, in the past, Ring didn’t seem in any hurry to fix such problems – despite the obvious harm to customers.

One difference in this instance, however, is that this time, the E2EE problems seems to coincide with a ransomware gang claiming a successful hack of Ring (and a threat to leak data). News stories on the matter alternately state that Ring is aware of the breach of a third-party vendor and is working with that company to learn more or that Ring is declining to confirm the third party breach or name the vendor. In any case, the ransomware threats would seem to be an even more compelling reason for Ring to increase customer privacy/security/safety by immediately fixing the current problems with the E2EE feature.

1 Like

Im also having this issue, i did everything too where I rebooted and even connected the cams to a mifi. This is troubling because I rely on the cameras inside to keep an eye on my disabled mother.


@Frustrated427 That’s very interesting. I agree. The issues started to occur around when this breach occurred. I imagine that it is likely connected. Especially if the breached third party somehow handled the E2EE side of things.

@ELMS Thanks for identifying that you too have this issue. Unfortunately, our discussions reveal that the issue is on Rings end, and we likely will have to wait for Ring to address the issue. And, being that they are in the middle of a data breach investigation, we are unlikely to see any improvements for the near future. Our best bet is to keep this discussion relevant so other members of the community can see this post.

Lastly, one last update: My battery camera (which is connected to a solar panel), still works. I am able to view the motion events on this E2EE camera. However, my other wired cameras (also enrolled in E2EE) fail to load motion events. This indicates the issue could be related to the firmware on the wired cameras. I am not sure.

All other Ring community members, please post here if you too are having issues with your End to End Encrypted cameras. Thanks.

1 Like

Over the past few days my cameras with end to end encryption enabled are not playing back video captured with motion detect feature, videos captured via live view are fine. When attempting to view the footage captured via motion detect the video loads to 99% than loads a second time to 98% then throws an error, also when trying to download the clip it gets to 99% then throws an error. I have reset them to factory and everything works ok untill i set up End to End Encryption again from fresh i have the same issue live view works but video captured via motion throws errors.

I have also reset my wifi router checked that the cameres have a good connection and rebooted the cameras from in app the lot im pretty sure this is an issuse of rings doing rather than one of my own.

Is there any way of getting this issue escalated or can i get some form of confirmation from ring that there aware of this issue?


Everyone I have spoken with in the community using E2EE cameras is having the same issue you describe: loading to 99%, going back to 0%, and reloading to 99% before getting the error.

I’m going to put in a call to Ring technical support in an attempt to flag the issue. Other than that, I am unaware of any channels to elevate the priority of the issue. Maybe if we all put in calls to technical support the issue will be elevated in priority?

1 Like

Hi. Hope all is well. Since the ring app was updated a few days ago, I haven’t been able to view my videos. It detects motion but when I try viewing it, I receive the “hmm something went wrong: there was an error while trying to play the video” error.
Will appreciate assistance as I’ve turned the camera off and on and my internet as well.

1 Like

Hi neighbors. If you have tried the suggested troubleshooting steps mentioned in the thread and are still having the same concern, the best course of action would be to call our support team so they can create a ticket and gather the appropriate data for our team to have when investigating this concern. Since the Community is a public forum, we are not able to gather the data needed from you here.

Caitlyn_Ring -

The current E2EE decryption problems should obviously be handled by Ring as a top priority, as they not only render the affected Ring wired doorbell and camera (security) devices as relatively useless – but place people and property at serious risk for seemingly no legitimate reason.

Thus, can you check with your “team” to determine the current status of fixing these problems? Is anyone even actively working on them?

Interestingly, I can suddenly view Ring (E2EE) video clips that were created TODAY due to motion, but not, for example, ones created YESTERDAY.

There are also multiple problems with the E2EE video clips themselves:

  • If the Video Recording Length option is set to 60 seconds, you’ll get a 7 second playback.
  • The E2EE videos are “jumpy” near the end, with missing frames (i.e., missing action).
1 Like

I have the same issue. I spent about an hour with Ring tech support. He failed to resolve the issue or find any configuration problems. In the end, the tech told me that “end to end” is no longer needed since all communication with Ring is already encrypted.

1 Like

If you use the Ring E2EE feature for any/all of your wired Ring doorbells and/or cameras… what is the current status of E2EE video clips that were created as a result of motion since the most recent E2EE problems began?

For example:

  • Are you still unable to view any such E2EE video clips?
  • Are you only able to view such E2EE video clips created in the last couple of days – but they have a number of problems which limit their usefulness for security purposes?
  • Are you only able to view such E2EE video clips created in the last couple of days – but they seem normal?
  • Are you able to view all such E2EE video clips that were created in the last 60 days – and they seem normal?

Although I can view E2EE video clips created as a result of motion in the last couple of days… the video clips suffer from a number of problems. They definitely are not of the same quality or length as older E2EE video clips or video clips created on devices that do not use the E2EE feature.

There are several complaints under (look for UnsuccessfulDecryptionException). I personally experienced this problem, all alarm recordings from my doorbell between Mar 11 5pm Eastern and Mar 21 8am Eastern are corrupted and cannot be played back. As of Mar 21st the problem appears to be resolved, the previous videos are still not accessible.

Ring support has proven to be useless. When I first contacted them, I was almost literally told to “… off” and call the number. Then the chat was closed and the phone number disappeared :slight_smile:

I managed to reach them on FB and there they reluctantly confirmed that there was an issue.

I contacted them today requesting the information on how to request a refund for 10-day outage, and I was told that the issue is still not resolved. I told them: if you have an ongoing outage for 10+ days, how come you did not inform the paying customers? No answer. Where to read about this outage? No answer.

Until the details are revealed, I think I would believe in the possibility of a security incident.

If Ring tells me to disable E2E encryption, the Ring devices go to the garbage bin. This is 2023. And whoever says that “e2e no longer needed” will be laughed at.

1 Like

grigoriev -

It sounds like your E2EE motion-generated video clips returned to normal as of March 21, 2023. It must be nice. Mine are a real mess. I doubt they could be used as evidence in court. They certainly don’t represent the quality of video clip one would expect from a security camera (or actually, from any camera that can generate video clips).

I agree there should have been strong, effective, ongoing communication by Ring on this issue. Affected customers certainly have a right to know what’s going on.

Did you notice that the following Ring website shows “No incidents reported” on every day that customers using E2EE were totally unable to view any motion-generated video clips for their wired cameras and doorbells?

It’s unfortunate that most people (including most Ring customers) probably don’t understand anything about E2EE. If they did, I suspect they’d be demanding it (at least as an option) for all forms of communication.

I hope more Ring Community members report their current status. (I’d hate to think I was the only customer who is having problems at this point.)

I’m having this same problem. I finally set up e2ee on my two ring wired doorbells yesterday, after owning them for about 6 mos. Between yesterday and this morning at 10 am i was able to playback the encrypted videos from motion events no problem. But I am getting the same error you all got when I try playing back any videos from this afternoon. I checked playstore and the app was last updated in 3/8, so its clearly not an app issue if they worked this morning but not this afternoon. I do hope it gets resolved very soon because I rely on these cameras for security.

Of course no sooner do I post than it starts working again. My videos from the afternoon are still not accessible, but the ones from 8 pm and after have been accessible again. I guess thats a good thing but hard to know if it will be reliable moving forward…