Dashboard thumbnail view for one camera not updating

I have 8 cameras setup on dashboard. All camera views on dashboard are updating every few mins except one of the cameras. The one camera just shows a static photo of the stickup cam but not a snapshot. Motion is successsfully recording but the dashboard thumbnail view never updates… The dashboard thumbnail view never updates for this one camera, all the others do. I’ve tried re-installing app, logging out/logging into the app, removed and re-added the camera, rebooting router. Good device health, 33 RSSI, 100% battery, Good battery and signal strengh are reported in device health report. This is an older Stick Up Cam. Same behavior occurs on both Win10 and Andriod app for this perticular camera. Any suggestions on how to resolve this issue?

Hey @RSAL. Is this a Stick Up Cam Battery? If so, I recommend to power cycle the camera by taking the battery out for 30 seconds and then putting it back in. Give it a couple hours to refresh it’s connection, and then see if it updates more frequently for you. Also, please check out our Ring Help Center Article about this feature and reference the bottom two FAQ’s for more information about this delay you are having.

I have the same problem with one of the cameras that I have. All others will update very frequently (within 40 sec.) and this one would not update. It is a indoor camera.

I have the same issue. Any solutions on how to fix this?

Hi @Drewmama! This usually happens when the unit has failed to update its firmware. Once the firmware updates, you’ll begin seeing images in your Camera previews. Firmware updates happen automatically, and can be confirmed in your Device Health, depending on device. As suggested above, a power cycle can also help with this. Check out our help center article for more information on the thumbnail features. I hope this helps! :slight_smile:

I have the same problem sometimes. I recently purchased the stick up cam plug-in, and even though it is a wired device, it acts like a battery device for the thumbnail. Given how the hardware for the non-POE stick up cams all seem to be the same and have a battery mode even on the plug in version, I can accept this behavior because there’s an explanation for it.

The issue with my unit is that sometimes it will not update the thumbnail even after several hours. I saw 3 hours as the last thumbnail on my plug-in stick up cam yesterday. (In comparison, my battery powered spotlight cam has consistently updated the thumbnail if seemingly more than 20 min have passed.)

But one thing that was a concern is that it totally missed capturing a family member arriving home. The camera should have definitely caught the movement, as movement occurs within 10 feet of the device. This made me wonder if the lack of the thumbnail update was an indicator of something wrong, though oddly snapshot capture is still working.

Can this be considered normal operation?

Firmware is up to date, connection strength is good, Gb fiber internet.

I’ve also had this same issue, over the past few months, on my hardwired Gen 1 Ring Doorbell. Initially, there was actually no photo, just a generic icon. After some resets and reboots, it now has a photo of me configuring the camera. Not that much of an improvement!

No thumbnail of any new videos update to the dashboard. Firmware up to date according to device health.

1 Like

Hey neighbors, happy to chime in here. Since a few of you are having this concern, as well as other concerns with the motion detection on your Ring device, it may be best if you reach out to our support team directly. As we are a neighbor-to-neighbor support forum, we’re not able to look as in-depth at your devices and what you’re experiencing specifically. Not to worry, as our support team can work with you directly to isolate the concern and find a solution.

You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 hereto see how to contact support. Feel free to come back and provide an update on what support recommends, as it may help others with a similar concern! :slight_smile:

Would you at least be able to tell us what is supposed to trigger the thumbnail refresh on battery powered devices? E.g., more than 20 min since last refresh, etc.?