Dashboard not loading, just keeps “spinning”

Any idea on why this is happening? It’s on all four of my IOS devices.

1 Like

Same here

Thanks for reporting neighbors, stay tuned for more information at status.ring.com :slight_smile:

Hey neighbors! We did have this concern with the Dashboard not loading for some neighbors, but this issue has since been resolved. Please attempt to force close your app and re-load the app to ensure that your Dashboard is working as it should. Thank you neighbors! :slight_smile:

I don’t think you solved the issue yet, i 'm encountering the similar issue

*my my **RSSI is 36, and it’s really close to the router. **

*battery is fully charged 100% to 99%

I just installed my security cams last weekend, it worked well. however, since yesterday around 8 pm PTS, the cams haven’t worked anymore. I’ve tried to reconnect them to wifi, but all failed. I didn’t change any setting on the cams or the router.

it’s stuck with “activating devices” and if i tried to see the video earlier, it shows “thefootage is unavalible”

I’ve reinstalled the app and it’s the same.

The customer service sucks, the only way is to call or leave a comment on the community.

NO LIVE CHAT? I regret that I bought this buggy stuffs, i’m going to tell all the ppl I know stay away from this

Hey @ringisterrible. Thank you for reaching out to us! This topic was in regards to a trending concern that we had with the performance of our app being limited. This has since been resolved and any concern you’re having may be due to your specific devices or network. If you are in need of immediate support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Depending on your region, we may not have email support available, and chat support has been removed at this time while our chat agents are helping out with the phone support that we need. I apologize for any inconvenience this may have caused you at this time. I can help you out further here, and in your situation and knowing what you have done, I have a couple steps you can take to see if you can get your devices working again.

I’m not sure what security cameras you do have, but the process should be the same for all of the devices. Please remove the device from your Ring account, and ensure you have any videos you want saved before you do so. Once the devices are removed, please reset the device by pressing and holding the setup button for 30 seconds. After 30 seconds, give the device a few minutes to reset. After this time has passed, set the devices back up as you once did. Ensure you can view the Live View after the firmware has updated on each device after this fresh set up.

When it comes to your network, you may need to make some changes to ensure the devices do not get kicked off the network like it sounds they have since. You will need to check that all ports and protocols are opened and adjusted to allow the Ring devices to connect and stay connected. Feel free to let me know how this goes and if I can help further! :slight_smile:

Since this mornings update (06-09-20) of desktop app, live views do not load on both wired and battery operated devices. Tried force quit, realunch, nothing works to allow live view