(Critical) "Privacy Zones" Bugs

Video clips for my doorbell now show what (visually) appears to be a (large, solid, Black) “Privacy” feature rectangle blocking an important portion of the view. This occurs with the Live view feature itself as well as with video clips that were created with the following features:

  • Live View
  • Motion Detection

I have tried using the Ring Privacy feature to see if the rectangular block could be deleted, to no avail.

I tried re-installing the Ring app on one iPadOS device, which not only failed to solve the original problem, but created additional problems. The same issues occur on another iPadOS device running a different version of the operating system.

Obviously, Ring’s Privacy feature is a very flaky, poorly designed, relatively useless feature in the best of times. It’s not clear if this particular problem, however, is due, at least in part, to the fact that this doorbell is using Ring’s End-to-Encryption feature.

I definitely do NOT want to try pressing the Setup button on the doorbell itself because I know (from experience), what a nightmare the process can become.


Ring moderators:

  • Could someone please report this problem? (Please do NOT suggest I call Ring Technical Support.)

The device is running the following hardware/software:

  • Ring Doorbell Pro 2
  • iPadOS version: 14.8.1
  • Ring app version: 5.46.0
  • Ring End-to-End Encryption

Hi @Frustrated427. Can you please share a screenshot or video example of this back rectangle on your Live View screen or your recordings? I’d like to take a look and share it with my team, but an example of what you’re seeing would be helpful. You can grab a share link from a previous video by going into the Event History in your Ring App and choosing to share it via email. From there, copy the link that is generated and paste the link in the body of your post. Alternatively, you can take a screen recording and upload the video elsewhere, such as YouTube, and then share the link to the video in your reply. A screenshot would also be helpful.

Caitlyn_Ring -

I am unable to share any screenshots and/or video clips due to privacy/security concerns.

I can tell you, however, that the large, solid, dark Black rectangle looks exactly like a privacy zone. In other words, you can not see anything underneath the rectangle because it is too dark.

It appears that the Privacy feature basically does not work in the iPadOS version of the Ring app – if End-toEnd Encryption is activated on the Ring device. For example, you can NOT:

  • Add a privacy zone
  • Select an existing privacy zone
  • Display the name/number of a privacy zone
  • Modify a privacy zone
  • Move a privacy zone
  • Delete a privacy zone

In fact, the only thing you can do if you select the “Edit Privacy Zones” button is:

  • Display a camera view (which includes the Black rectangle)
  • Select the “Back” (<) icon to return to the previous screen

You can try disabling End-To-End Encryption to see if you can then edit this Privacy Zone and remove it before re-enabling End-To-End Encryption.There should be a trash can icon after you tap the zone and then tap Edit Privacy Zones. If you use the Ring App on multiple tablets or phones, ensure all of them are enrolled in End-To-End Encryption, you can find steps on that here.

If these suggestions don’t resolve this, you would need to contact support for further assistance and to log this feedback. Please give our support team a call at one of the numbers available here and feel free to reference this thread when you call. If you are outside of the US, please visit here to see how to contact support.

I just installed the latest version of the Ring app and the Ring “Privacy Zone” feature does not work when using the following hardware/software:

  • Ring Doorbell Pro 2
  • iPadOS (version: 15.2.1)
  • Ring app (version: 5.48.0)
  • Ring End-to-End Encryption

In other words, if you select the “Edit Privacy Zones” button in the Ring app, you can NOT:

  • Add a Privacy Zone
  • Modify a Privacy Zone
  • Delete a Privacy Zone

In fact, you can’t do ANYTHING on the (truncated) screen view that is displayed – except use the “<“ icon in the top left corner to return to the previous screen.

Interestingly, in the Ring app (iPadOS version 5.48.0), I realized that the Privacy Zones feature is far more buggy/unstable than it appeared. Armed with that knowledge, I decided to try various troubleshooting techniques.

Although my efforts initially did not appear to work – when I accessed the Ring app a bit later, I noticed that the “unselectable” privacy zone had finally disappeared from the Camera Preview Tile of the doorbell as well as from Live View. This is quite a relief, as nothing I had tried previously had helped.

Of course, the overall Privacy Zone user interface design issues, programming bugs, and software instability still exist – but hopefully, the privacy zone that previously could not be edited and/or deleted is gone for good.

1 Like