Connection issues with 2nd gen indoor plug in security cameras


I bought several 2nd gen indoor plug in security cameras and also stick up cameras. i had no problem installing the stick up cameras but i kept getting connection errors when i tried to install the plug in ones. it says no internet connection is found. ?? how is this possible if my stick up cameras can connect? i tried hard reset the plug in ones and still received the same error msg. please advise. I even changed the wifi network id to one single word and no luck. I have a TP-Link Deco mesh system and I looked up on google for ppl with similar problems. I turned fast beaming and beam forming off and didn’t work
please help thanks.


I have similar setup and issues to you.
I have TPLink Omada mesh system with multiple ISPs.

As I stated in my separate post, I had doorbell and other cameras working on Ring. I added 2 more cameras without issue, then a few days after adding, they dropped and refuse to connect again.

My error code stated that password was incorrect, but tried again (20 times) with different networks only to return same issue.

I wonder if there is some global issue with adding additional cams. Sorry that I do not have any further suggestion; just empathy.

Hi @leapmach. Would you mind sharing a screenshot of the error message you’re receiving in the Ring app during the setup process? Is your wifi network 2.4GHz, 5GHz, or dual-band? How far from your wifi access point are the Stick Up Cams?

A post was split to a new topic: Cant access live view on stick up cam