Connected z-wave devices not being discovered by Alexa

I have the exact same issue where I cannot add a Z-Wave device into Alexa after removing it. It’s Alexa that is the issue. Will try to call them to get help.

I called and had Ring and Alexa support on the line at the same time for over an hour. They no longer support z-wave through ring and you are SOL - buy a new device is what they had to eventually tell me (even though my z-wave through ring device worked until the account was disassociated and re-associated with my Alexa account.

@Caitlyn_Ring @Tom_Ring , can one of you please confirm if Alexa still supports controlling Works with Ring Z-Wave devices through the Ring app? I find it hard to understand that we would lose this functionality with no notice from Ring or Alexa.

1 Like

I just added a z-wave switch (Enbrighten GE) and Ring discovers it.
However it is not showing up in Alexa on my phone.

I have updated both the ring and the Alexa app.

@Caitlyn_Ring @Tom_Ring could you please ask the engineering team on what needs to be done to ensure that this works.

1 Like

Problem still not fixed. This isnt a Ring issue, its Amazon. Called Amazon, less than helpful. Had to call three separate times. The first refused to submit a ticket until I ran through all the “white binder” steps, basically assumed I didn’t know anything about smart home devices or how they work. Second kept trying to get me to call Ring and didn’t know Amazon owned ring, that they only manufacture Alexa devices. I must say it was fun when I asked Alexa who owned ring and allowed the customer service agent listen to the response. The third finally submitted (at least said they were) a ticket after having to repeat myself five times and pleading to submit a ticket. I’m not convinced this occurred.

Basically, I’m not confident Amazon has a grasp on the situation. To go this long without somebody (Amazon or Ring) taking notice of this situation or being able to provide a reason on what is happening, or why this feature was removed, is not good. The whole reason I got the Ring in the first place was the one stop shop for my security devices and Z-wave capability to pair non Ring devices. Without that capability, I have no further use for the system as there are much better hubs where I can better customize security as well. Already purchased a secondary Hub for the transition.

I wish I had found this thread before I tried what they are calling their backend fix. I was trying to add one new device and now I have 9 that used to work that will no longer connect. The fact that the Ring alarm doubled as a Z wave hub is the main reason I’m using it. But I need Alexa to find those devices in order to do routines. If they can’t get this fixed soon, I’ll be dropping my alarm subscription and switching to another system. That seems pretty likely considering that the Alexa dev team can’t seem to figure out that there is a problem at all.

Hi neighbors. As Caitlyn has mentioned, our team has corrected this issue with a backend fix. You may need to disable the Ring skill and enable it again, as well as discover your devices again, for this fix to take affect. If you are still experiencing this issue, and you’ve already called support, feel free to send us a message on Facebook @Ring so one of our support agents can take a closer look. I’ll be marking this post as a solution so other neighbors can easily find this information. Thank you.

1 Like


as you can see between this thread and the other, plenty of people have replied that nothing is fixed. This should not be marked resolved. Alexa is still unable to discover “works with Ring” ZWave devices.

I called support the morning this was said to be fixed: Ring support was not at all knowledgeable of the original problem, or what backend fix was said to resolve it. They only advised it’s an Amazon problem since everything works fine in the Ring app.

Why would you ever mark this as resolved with the amount of people replying it’s still an issue?

New here; subscribed specifically for this issue. Just got my base station today and couldn’t add the Z-wave switches to Alexa despite having them detected by Ring. Attempted backend fix with no success.

The whole point of the Z-wave switches is to be able to program the lighting based on Ring camera/alarm activity. This is a disappointing development that needs to be rectified.

No Tom. The issue is not fixed. I disable and re-enable the skill each day and rescan for devices. Just in the hopes it will be up and running. Removing any previous “works with ring” devices only results in those devices unable to found by Alexa. They will fontinue to work in the ring app, but thats it. We need another “back-end fix”.

I agree with everyone who says it’s not working still. I’ve previously added a UltraPro Z-wave switch to my Ring, and Alexa was able to discover it without problems. I bought the exact same UltraPro switch again… and it won’t connect to Alexa. I’m no expert, but I think the problem is any “works with Ring z-wave product” MUST be added via Security devices. I think a quick and simple fix would be to allow users in the Ring App to add or assign these devices into a Group. The Alexa app easily recognizes when you create a new Group in the Ring app, and if we could just have the ability to assign the device to a group in the device settings… Alexa can control the Group and… problem solved… or at least a potential workaround until the whatever the actual problem can be solved. I know this can be fixed because my other z-wave light switch still works great with Alexa via Ring.

1 Like

@Tom_Ring has someone in your support center actually verified that the backend is fixed.
Are they any recommended steps to follow to make sure things work (what version of ring app, Alexa app, steps to follow0.

I just finished a remodel in our home, and have designed the home around the ring z-wave hub+ Alexa.

please do verify it. before marking it as solved.

1 Like

It seems Tom and Caitlynn aren’t bothering to read ANYONE’S replies and CONTINUE to offer the “backend fix” that CLEARLY isn’t a fix! And to add insult to injury, Tom is telling everyone: “You may need to disable the Ring skill and enable it again, as well as discover your devices again, for this fix to take affect”, causing everyone to lose their still working “works with Ring” devices! We need an ACTUAL knowledgeable person to reply to us and confirm that either our devices are no longer supported to work with Alexa, or let us know if this is actually being looked into. Sadly I don’t think that will happen. As I mentioned early on in a comment, I went ahead and bought the Aeotec hub and I am back in business with Alexa. I knew better than to depend on Ring or Amazon to actually care or bother with this issue, given the repeated, redundant “fix” responses. I am going to keep following this thread though, as I’m curious if I will be proven wrong. And I really hope I am. Because some people can’t, or don’t want to spend more money on another hub when they shouldn’t even have to!


Still not working! I disabled/re-enabled Ring skill in Alexa.

Like others have said, I had all my lights (16) plus a few switches working perfectly and decided to add a new switch for something else. It would not show up on Alexa no matter what I tried so like a fool, I removed all the existing devices and now, instead of 1 device not working from Alexa, I have more than 20!! WHAT IS GOING ON? Why not come up with a warning instead of simply killing everything like this? I’ve been using Ring since day 1 (early adopter) and have come to rely on it. I pay my yearly dues and now this? REALLY?

I have an ultra pro switch and I’m having the same issue.

@Caitlyn_Ring @Tom_Ring Do you have any updates? This issue is still occurring.

Hi neighbors. The reason we ask you to call in or message our support team on Facebook is to collect information that cannot be collected here in the Community. This information is beneficial to our team when looking into an issue. Furthermore, our team has enough information that there is no further need to call in. This concern is actively being addressed and is being worked on to be resolved. Once we receive an update that this has been fixed, we will come back and comment. Thank you for your time and patience.

@Tom_Ring @Caitlyn_Ring I’m still having the same issue. I called ring support and they told me the issue is resolved. The only recommendation was to call Alexa support.

Any update?!?!

Same issue here. Have a ring alarm and added a new Z wave light switch. I try and avoid the Wi-Fi light switches as I don’t want it to add yet another device on my Wi-Fi (eero pro with about 80 devices).

My new Z wave device shows up in ring but not Alexa. Need to for automations! Help!!!