Connected z-wave devices not being discovered by Alexa

Facing the same issue. Tried the enable/disable as well. Anyone able to fix it?

1 Like

Facing the same problem. Alexa cannot discover new devices, including a device that Alexa discovered last week that I removed and tried to add back in. Disabling and enabling the skill does not resolve this issue. Someone please help!

1 Like

Having the same issue. Z-wave devices that you connect to the Ring Alarm Pro used to automatically show up as available devices in Alexa. These Z-wave devices no long show up in Alexa and it seems there is no way to add them to Alexa. You can see the Z-wave devices in the Ring app and control them there, but without Alexa you’re unable to automate any of those devices. Please help!

1 Like

Hey neighbors. Thank you for bringing this to our attention. We understand that we may need to dive into this concern. We’ll need you to call our support team so that we can create a ticket for this issue. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Another option is to send us a private message on Facebook @Ring. Thank you for your patience while we investigate this issue. If you have any other questions in the meantime, don’t hesitate to ask.

Any updates on this? It’s very frustrating that our Z-Wave devices no longer work with Alexa.

Hey neighbors, this issue was resolved with a backend fix. For any neighbors who continue to run into this issue, ask for Alexa to discover your devices again. If that doesn’t do the trick, removing and re-adding the devices should do the trick. Should this concern persist, you’ll want to follow up with our support team to further investigate. Thank you for your patience as our team worked on getting this taken care of! :slight_smile:

1 Like

Thank you @Caitlyn_Ring however at least for me, the issue is not resolved even after calling into support. Alexa is still unable to find a newly added ZWave switch.

After reading your post that it’s fixed I’ve:

  • Removed and re-added the ZWave switch twice in the Ring app. Each time it added fine and without issue, and works fine in the Ring app.

  • Unlinked and re-linked the Ring skill in Alexa.

  • Rebooted my base station.

I re-ran Discovery multiple times in between the above steps and Alexa still cannot find the switch despite it working fine in the Ring app.

Ring support stated it’s out of scope for their support since it’s working fine in the Ring app… I have 2 more of these same model switches that I had added last year at one point and they were discovered fine in Alexa at the time. It’s only this 3rd switch that I tried adding during the window which everyone else was reporting the same problem.

Very curious if anyone else having the issue was able to have Alexa discover the switch since the fix.

1 Like

@Caitlyn_Ring this issue is not resolved. Still cannot discover new “Works with Ring” Z-Wave devices added. Ring support continues to report they cannot support this issue as stated since it works fine in the Ring app.


I’m having the same problem. As of 3/12/22 this issue is NOT fixed.
I’ve tried re-adding and re-discovery several times with no luck. Existing switches work, but the new one I’m trying to add does not.

Hey neighbors, thanks for your continued feedback. The backend fix that our team released should resolve this. If it doesn’t, and the suggestions provided in the marked solution don’t work, further troubleshooting on this would require it to be escalated within our support team. I’ve passed this information along to ensure our support team is aware, and can escalate this as needed and gather the necessary details to investigate.

1 Like

The “backend fix” did not fix the issue! PLEASE ESCALATE!

“Backend fix” is a joke. It’s actually just logical steps that everyone has already tried with no luck. Without first researching thoroughly, I used Amazon’s “fix” of disabling the Ring skill and one by one, deleting my devices from Alexa. Sadly this was the WRONG thing to do, because I lost ALL of my -still functioning- “works with Ring” devices as Alexa only discovered actual Ring branded devices and my z-wave door locks. I tried the “backend fix” after this happened. Haha. This is sad. Amazon owns Ring. I expected better. Jokes on me.


Just call ring support as [Caitlyn_Ring] suggested. They had the audacity to tell me to call Leviton! Classic kicking the can down the road. This is NOT Leviton, This is NOT GE, this is RING/ALEXA problem. I have 20 zwave Leviton switches that work no problem. just added 10 more Leviton switches (same model) that work perfect with Ring but NOT discoverable by Alexa. Ring is telling us to use Alexa to do all the things the Ring team won’t develop into their Ring app but now won’t support the connection to Alexa?? cmon. I have tried ALL remedies (re-install Alexa, re-install switches, disable/re-enable skills, ask Alexa to discover all devices, etc) NOTHING WORKS. I suspect this is a code change in or around Feb 25 on the RING side that has affected its ability to pass new zwave device type=switch through the Ring Skill api to Alexa. Regardless, Ring team needs to get ON THIS NOW. still on phone with Ring support as I write this as they “try” to get someone from alarm team to take this seriously. sad.


Leviton issue? lol! So then it must also be a GE/UltraPro and Zooz issue because those are the ones that I have. Give me a break. All we are getting is a copy/paste response about a “backend” fix every time. Sadly, I don’t think this issue is any kind of a priority and won’t be fixed anytime soon so I just went ahead and bought an Aeotec hub for allllll of my “works with Ring” devices.

Does Aeotec hub work with Alexa insofar that you can script behavior (i.e. turn lights on) when certain Ring events happen?

Yes. You link your SmartThings account with your Ring account. Then you can create routines or automations in Alexa or SmartThings for the lights to trigger during Ring events… whichever you prefer. It’s easier to do it through Alexa though, and more extensive… but you do have the option to do some of it in SmartThings.

1 Like

Just completed a test that was revealing on this problem (that still exists). I opened a Simple Commands account and linked it to my Ring account. Surprisingly, it WAS able to see ALL of my Leviton switches that were recently installed on Ring. This indicates that this is NOT necessarily a Ring problem, but rather an Alexa Problem. Assuming SC is utilizing the same API that Alexa does for access to Ring database. Given that Ring and Alexa are both owned by Amazon and that Ring is leaning on Alexa dev team to deliver features that frankly Ring should have as a standalone system, it is incumbent on RING AND ALEXA to figure out wtf is going on here. It wouldn’t surprise me if Alexa’s Ring Skill had better/different api access than say, a small unaffiliated 3rd party startup like SC. BUT, if it is using the same, it appears that ALEXA is the problem here.


I have the exact same issue where I cannot add a Z-Wave device into Alexa after removing it. It’s Alexa that is the issue. Will try to call them to get help.

I called and had Ring and Alexa support on the line at the same time for over an hour. They no longer support z-wave through ring and you are SOL - buy a new device is what they had to eventually tell me (even though my z-wave through ring device worked until the account was disassociated and re-associated with my Alexa account.

@Caitlyn_Ring @Tom_Ring , can one of you please confirm if Alexa still supports controlling Works with Ring Z-Wave devices through the Ring app? I find it hard to understand that we would lose this functionality with no notice from Ring or Alexa.

1 Like