Chime Won't Setup

I bought a new Chime and it won’t setup.

I plug it in and follow the app instructions and I get to the screen where it says to join the Ring Setup network, which my Android does, and then it just repeats asking me if the light is flashing green, join Ring Setup, then repeat again and again, never going anywhere.

My app setup my Doorbell no problem but this is not doing anything.

Hey @rtsoi1978. Could you please try setting up the Chime on another device, such as another phone or tablet that has the Ring app on there? Once you’ve tried the setup on another device, let me know if you get the same loop run around!

I tried it on another phone, different manufacturer, different version of Android, same problem.

@rtsoi1978 Thank you for giving that a try! Last thing you could give a try is to reset the device by pressing and holding the button on the side for 30 seconds. If you do not see a button on the side but instead a small hole, please get a paperclip or pin to press and release after 30 seconds of holding down. Ensure as well that the device is plugged in during this reset process. If the setup continues to fails after the reset, please give our support team a call here.

I changed my wifi network but one of my chimes will not reset. Pushing the reset button for 5, 15, or even 30 seconds does not lead the Blue ring light to pulse. I tried 2 weeks ago, then left unplugged for 2 weeks and tried again today. Still doesn’t work. Any advice? I was able to move doorbell and another chime to new network just fine.