Chime Will Not Set-up

I need help! Chime Will Not Set-up

So just trying to troubleshoot why this ring chime pro will not connect correctly, just come off the phone from support in the USA, even they are confused.

So tried adding it normally with the QR code or the 5 digit number and takes me through the process then has trouble connecting to the wifi supposedly even though its registered on my router with an ip address.

It then tells me and flashes red saying connected to wifi but no internet.

Tried reinstalling the app on two devices and two app stores.

Same problem anyone else know a fix?

Hey @Naima63. Were you able to get the device set up? If you are still unable to set up the Chime, please let me know where you are getting stuck at so I can look into this further! In addition, if you need immediate support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.


I’m trying to setup my 2nd Gen Chime and I get to the setup wifi part, the chime flashes blue then goes to solid red. I’ve tried moving it closer to an access point but that doesn’t seem to do it.

Any suggestions?


I have the same problem. Tried 2 ring chime 2nd gen. Get to connect to wifi and green light keeps flashing and the message connect to ring network without internet. Got a ring chime pro yesterday and I have the same trouble

Sorry to hear about this experience, neighbors! If your Chime is still not setting up as intended, please try removing and reinstalling the Ring app on your mobile device. I recommend also attempting setup in different outlets in your home, as well as close to your wifi router, if you have not already. There are also two methods for setup which are scanning, or setting up without scanning, try both.

If setup is still not completing as intended, the best next step will be to reset your Chime by holding the setup button for 20 seconds. Feel free to let us know how this goes!

Same issue here, worst client support on the planet. they can’t solve anything other than to suggest buy a new one and install all over again. Nest here we come.

Don’t call client support, they are worthless. Their suggestion to me was to buy a new one and try again.

Just bought a Chime Pro 2nd Gen. Right out of the box, it will not complete the setup, fails to connect to the internet at the end of the wifi setup. Have tried like 10 times now, rebooted wifi, hard reset the Chime, updated the Ring App, scanned the code, used the 5 digit code, yada yada. Nothing works. I was going to call Ring but sounds like that’ll be a waste of time. Anybody got this to work yet? Thanks.

The saga continues! This is my experience.

I had the same problem, I bought a new Chime Pro 2 on Amazon and it got to the step to connect to Wi-Fi it would say it could not connect. But I kept trying the “same” network I used for my Ring Video Door bell. After resetting completely - 30 FULL seconds - I did the setup again. This time I did not use the same network as previous. I then selected the network I wanted to use which “was the same network” but this time I could put in a password.

After that the setup worked like a charm and my Chime Pro 2 is now working.

Key - Do not select the same network - act like it is a different network but then select the same network. Seems to resolve the problem.


DiveMedic, Thanks for that workaround tip. It worked for me!

Walter in Davie, FL


Just a final follow-up here…I gave up and returned the Chime Pro Gen 2. I ordered a Gen 1 model, took it out of the box and within 5 minutes it was setup and working perfectly. There must be something wrong with the Gen 2 models. Thanks for everyone’s responses.

Thanks for the tip! That worked for me!


Hi there , i had a similar problem. And after some fault finding results, my solution was that the chime needs to be signed in to your router as you would with any new device. So in summary you input your router password like you did when you first installed your Ring doorbell . And mine works perfect now. Good luck


Hi guys, this worked perfectly with network password.


Try this. When it asks for your wifi and shows up automatically…DO NOT continue. Select “no” and it will allow you to choose your wifi and manually put in the password. I believe the issue here is the password. I had the same issues you all have until I manually put in my wifi password rather letting the app try to access it.

Let me know if that works!


I have a similar issue. I hold the reset button for 5 or 10 or 30 seconds. The light will flash quickly for a few seconds, then go back to solid blue. I can’t get it into setup mode

I only got he Chime Pro to connect when I used the sign-in screen plus “advanced” tab to choose DHCP instead of static IP.

THANK YOU! This finally got my chime working, after trying everything else I could think of/researched.