Chime stuck on firmware update

Hi all,

Obtained Ring Video Doorbell Pro as a second hand product. Doorbell working fine, incl. setup and network connection.

But chime have problems: installation seems to go fine, but stucks into firmware update.

Tried so far:

  • reset button 5 secs / 60 secs - this enables discovery
  • switch off for multiple hours
  • let it update for 10 hours
  • remove device - add device on app

Latest trials goes as following:

  • selecting: devices, chime, device health (showing firmware up-to-date), reconnect to wifi
  • 5 second reset -> light pulses very fast -> fast -> slow
  • tap to connect chime -> selected the only chime I own
  • not using previous wifi -> selecting wifi and entering (copy-pasting) pw
  • obtaining success message (after phone reconnected to real network); chime light has started pulsing fast instead of slow
  • obtaining eternal “updating firmware” message
  • according to the router, the Chime is connected and obtained IP (ending .156), and it communicates quite constantly aprx 2…9 kbps downlink

I’m quite exhausted on this: is there some error on chime, or shall I wait more to get fw updated? Am I missing something on this, shall I do something differently?

  • Pekka

No advice, but I am having the exact same issue with our Ring Chime. I have tried everything I can think of and it keeps getting stuck on the firmware update. We also have a Ring Chime Pro and were able to set that one up without an issue.

Hi,

Additional info after more troubleshooting:

  • the Chime communicates to network: I assigned new static IP for it in DHCP server, and it was updated to Ring during the night

  • the Chime communicates to DNS server quite often to query IP for fw.ring.com

  • after IP query, the Chime communicates (via SSL transmission) to one of the IP obtained from DNS server, f. ex. ec2-34-228-178-128.compute-1.amazonaws.com, with packet lengths varying from 0 to hundreds of bytes (both inbound and outbound traffic)

-> therefore it seems to me that the Chime communicates to home, but somehow it does not respond to back-end system to provide health information to user

Here is the traffic profile for aprx 10 hours or something today attached.

Any ideas?

Best regards,

  • Pekka

Hi Neighbors. With all the troubleshooting you’ve done, you should have been able to make progress with your Chime. Since you are still having issues, I would suggest reaching out to our support team to further assist with this. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.