Chime stuck in updating firmware, alternating blue and green led circle

Hi,
My chime pro gen 2 gets stuck on update firmware and becomes useless. I am able to reset (holding the button at plugin), and am able to connect to my wifi network, but then it always goes straight to updating firmware and is not able to finish this update circle. I have waited for many hours, still it does not finish. It keeps forever alternating between the blue and the green light.

Any tips on how to break this cycle?

Hi @einarso. I would also recommend trying to bring the Chime Pro into the same room as your router to see if that helps. If you have tried this step and still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

I have tried having it in the same room as router, next to the router - everything. I hate beeing stuck on telephone support, but seems like that is the only way from here.

By the way - everybody hates telephone support, so why are businesses still forcing people to go via the telephone support channel?