Chime Solid Blue Light

Hey all, my Chime (about 3 years old) all of a sudden decided to stop working. All I have is a solid blue light on the device and it does not connect at all. When i try to reset to resync or hard reset the device (15 seconds on the small push pin button) i get no response. Is there any other way to hard reset this or is this one kaput?

I have an image of the chime attached for reference, just a solid blue pattern. No blinking, no response when i try to reset it.

Have you tried unplugging the Chime and plugging it into a different outlet? If that doesn’t work, nor did the Chime reset, you may need to call support for a more indepth look into this. Thanks!

1 Like


Must be a 3 year rule on the Chim, mine has just done the same thing and can’t get it to reset.

Did you get a fix for your chime, are you able to share?



1 Like

I think a solid blue light means the chime is connected. Mine is working fine, and has a solid blue light. So if you have a solid blue, I would assume it is working and connected. Frist step, unplug the chime to reboot it.

Do you have a network monitor app? I can see my chime connected to wifi in my network app. If you can see the chime in the network app, then there is a communication problem between the Ring app and the chime. Try signing in and out of the Ring app. If the light is blue and you cannot see the chime in your network app, then I bet you have a chime problem.

Just a few trouble shooting thoughts . . .

1 Like

A month or so ago my Chime stopped working. I have unplugged reset and started over with Chime numerous times and all I have is a solid blue RING. 5 second or 15 second reset, 4 different plugs etc… and only my chime pro is working but not the CHIME. What happened? I am the 3rd one on here with the exact same problem and not sure what to do. Mine too is close to 3 years old. I will call support on Monday. Thanks!

Good Luck!!

I couln’t get the Chime to connect, gave up and bought a Chime Pro, connected the Pro without any issues. So i’m guessing my old Chime just died.

Yes my chime pro re- connected but it looks like my chime for upstairs is dead. 3 year life kinda sucks and if dead then why the blue ring logo stays lit? Thanks for input!

Yep, spot on, 3 years sucks and why have the blue Ring logo lit if the thing is dead!

Here you go Ring a couple of unhappy customers with the lifespan of your products and I bet we aren’t the only ones.

Mine is also right at the 3 year mark and I also have a solid blue light… The app shows that the chime is not connected. The reset procedures, both 5 and 15 second as well as trying different plug locations does not work.

The responses from the Ring representatives on this forum is deafening!!!

1 Like

Why don’t you call customer support?
Call Us
US: +1(800) 656-1918 (24/7)
US: +1(888) 981-8993 (Español - 24/7)
INTL: +1(310) 929-7085 (24/7)

I am also having this problem.

Chime is not connecting but I have a solid blue light. I have tried unplugging it for more than 24 hours. Also, resetting it with two taps of the reset, 5 seconds, and 15 seconds. All failed multiple times.

I guess we could all individually call support … -OR- … Ring could just supply some real world solutions here for all of us.

disappointing :confused:

P.S. If you have SmartThings and Echo Speaks then you can have your Echo devices announce your doorbell as I have done.

Hey neighbors! A solid blue light on your Chime or Chime Pro is an indicator that there is power reaching the device. Whether online or not, this light will be blue but should, of course, be blinking to indicate setup mode.

If your Chime Pro is not online, try pushing the setup button on the side which should cause the blue light to blink. You may select “reconnect”, in your Chime’s device health section, or start a new setup in the app, and follow those steps.

I recommend also trying another outlet, and locating the Chime Pro closer to the router during the reconnection attempt. If this does not result in a successful connection, our support team will be happy to assist further, at 800-656-1918.

Same problem here - bought 2 in 12/2016 - one of them stop working. I tried everything they said; contacted support - basically they asked me to reset it repeatly with them - still no go. Tech support had me repeated the process and wanted me to try reset on different plugs and different devices …

After few times, I gave up on them because they are just not helpful.

To recap, when I plug in power, there is blue light (very dime); and wont connect. If I try reset (5 second, 15 seconds or even longer) - it never get to the point that "pulses slowly.

If anyone has any additional info, please let me know. Wondering if I need to spend another $30 to get a new one.


If you have an Echo device you can use that according to this article.

I posted above my solution that uses SmartThings and Echo Dots but it appears you can do it directly with an Echo Dot now.

1 Like

@Tokagadget, went through all that stuff myself. The Chime is dead, to save you time just buy another one. I would recommend the Ring Chime Pro with the wi-fi extender.

I have 3 Ring Chime all around 3 years old. Is this the max lifetime? All light blue, suddenly all shows disconnected in the app. Got 2 back online, but 3 is only showing blue light, even with 5 sec or 15 sec reset. What to do?

Yep, it appears the Ring Chimes last about 3 years, possibly a faulty batch, who knows. Sounds like it’s dead, you may as well go out and buy a new one. I’d go for the Ring Chime Pro with the wi-fi extender, a little bit more expensive but more versatile. Good Luck.

ps. you can try contacting Ring support, contact details in the thread above, it would be interesting to hear what they say.

1 Like

Second RIng Chime gone offline and unusable in as many weeks here. Multiple reset etc has no effect. It’s too much of a coincidence that it’s happening now together after they were all bought between 3 and 4 years ago. This sounds like a firmware problem but all claimed to be up-to-date.

We have the same issue. hold reset for 30 seconds and nothing. Multiple plugs. unit suddenly stopped working and mine also is 3 years old, been in the new house 3 yrs 2 mo so i know the age. not sure i will add another, likely start to look at alternatives if product need replaced this often, as there seem to be a lot of people with 3 year old units that wont reset.