Chime "Setup didn't complete"

Hi there,

I’ve tried every suggestion I could find so hoping someone may have an answer here. I bought a Chime with my Video Doorbell to compliment the three other Ring cameras we have. The Doorbell (and all the other devices) have connected fine to our Google Wifi Mesh but the Chime will no complete the setup. Being diligent, I’ve tried the following:

  1. Connecting to the Google Wifi, within 1 foot of one of the Wifi APs and 3 feet of the Doorbell

  2. Connecting to the Primary Wifi AP

  3. Connecting to an SSID that runs directly from my internet modem/router - same internet connection but different SSID/network

  4. Connecting to the network at my office

  5. Connecting to a personal hotspot on iPhone, Samsung Galaxy and laptops

  6. Running the app from various iPhones and Android phones

The result on all is the same - I can select the Wifi network I want the chime to join, it sends my phone back to it’s original Wifi network, tells me “Chime is joining the wifi network” and then eventually times out and says “Setup didn’t complete” and I need to reset the Chime and start again.

The thing is, the Chime does connect to the network, I can monitor it getting an IP and transmitting data over a long period of time and I can even login to the mysimplelink page using the assigned IP. The problem seems to be with the Ring app/Ring servers recognising the Chime? Keep in mind this is from many different phones and many, unrelated networks. This is also the only device we have issues with.

Any ideas/suggestions?

1 Like

My Chime setup tells me the network isnt available . BUT everything other device is working. ??

The same problem here

Thank you for your post, I have the same problem. Did you ever get it resolved?

no, tried lot of times, with an open SSID, away from router…but no way to get it working.

Thank you for the update. I spoke to the online support and went through setup via a mobile hotspot and guest wifi as well as my wifi, all with the same result that it failed completing setup. They are sending a replacement chime.

1 Like

Thanks I will return mine as well and try another as well

Good Luck

Cheers

1 Like

I also went through online support and am getting mine returned, though I don’t have high hopes as these things seem to be very problematic. I’m hoping that a new one will have updated firmware on it that resolves the issue. What I really wanted was a refund so I could buy the (cheaper) Amazon Echo Dot which would work a sa Chime and allow voice control etc. Oh well…

I have exactly the same problem. Tried everything you did and nothing works. Brand new unit. If anybody has a solution it will be appreciated. I am in South Africa so calling the US support number will turn out more expensive than the chime itself.

Call Us
US: +1(800) 656-1918 (24/7)
US: +1(888) 981-8993 (Español - 24/7)
INTL: +1(310) 929-7085 (24/7)
They do have an international number

My new chime arrived and went through the same setup as before with the same result, the chime setup failed on the last step. However, I was able to get the chime to work after some experimentation. Here’s what I did. Note some of these steps may not be necessary but I put them here just in case.

* Used an extension lead and plugged my chime into it so the chime was on my doorstep close to the doorbell.

* plugged my router into the extension lead and placed that on my doorstep as well so it was close to both my doorbell and chime.

* Switched off the 5ghz wifi option on my router and then restarted. This was just in case for whatever reason the chime on normal wifi couldn’t communicate fully with the doorbell on 5ghz wifi.

* Restarted the router.

* Went through the chime device setup using the app. When prompted to join my home wifi which it had auto selected chose not to, instead selecting the same wifi from the list displayed so it forced me to enter the wifi password (just in case there was a problem with the stored password).

* This time the device completed the setup correctly and I verified it worked by ringing the doorbell.

* Moved the router back to its normal location and switched 5ghz wifi back on again.

*Moved the chime to the preferred location in the house and restarted the router again. The doorbell connected to 5ghz wifi, the chime connected to normal wifi and all are working as expected.

Seems that when setting up the chime it must be very close to both the doorbell *and* the router, ideally within line of sight to both and within a few feet.

Out of all that. The biggest thing was turning off the 5ghz. That is one of the most common issues. Most routers now broadcast the same SSID for both frequencies. I was able to turn that feature off so that both showed up separately.

1 Like

My router broadcast two different ssids for 2.4 and 5 ghz. I will turning off the 5ghz one and try again. Dont have a lot of faith in it. Question is why does the firmware has to be updated before it will work. Surely it should ship with the right firmware. Is there any way to log into the chime and flash the firmware manually?

Spend a further 4 hours trying to sort this out no luck.

some more info:

I have a Netgear Nighthawk R6400v2 router.

I have scanned the internet and tried various setting with no luck

i have reserved ip address for the chime and I can see that it connects to this addresses

i can ping the chime from a connected pc and it responds

only thing I can guess is that there is problem communicating to the Ring servers as it get stuck on final connecting part of the setup

Any help will be appreceated otherwise all I can think is the unit is defective and should be replaced.

The only other thing I can suggest is seeing if you need to open any ports on your router. I didn’t need to for my BT Homehub but here’s the link… https://support.ring.com/hc/en-gb/articles/205385394-What-Ports-Do-I-Need-to-Open-in-My-Firewall-for-Ring-Doorbells-and-Chimes-

Surely their is a fault with these chimes. It should be a plug in and work unit.

Moving your Router to other places and having to put the chime right next to the doorbell is not how it should be. RIng obviously need to sort this out as I know of so many that it’s happening too. I have replaced mine with another and same problem. Always saying no wi fi. available???

Same problem here. I have soft reset (5 sec.) and hard reset (15 sec.), rebooted my modem and router. Using the Eero router with 4 beacons. So far have two days into this Chime. It was connected then all of a sudden, not connected. Have read everything I can find and tried everything I can find. Even turned off DATA as that was one of the fixes. Nothing works! I love this device and have the brand new one coming in a week. But need to get this working. Thanks for any help.

1 Like

it will not give me an adrees to conect