Chime Pro won't pair

My Chime Pro (about 4 years old) doe not seem to pair with my Ring Hub or WiFi. It has been offline since I changed to a new router. But after reconnecting my hub, video doorbells and router to work together, I am having trouble with the Chime Pro. I have tried connecting the chime pro on the chime network as well as through my WiFi, following the instructions on my mobile app. No luck so far. When I tried locating the Chime Pro closer to the WiFi router, ensuring that I had power to the cube, no LED lights appear, as if it is dead. Any suggestions?

Hi @RingOKC. If your Chime Pro is unresponsive and not lighting up, try factory resetting it to see if it helps. To factory reset your Chime Pro, press and hold the setup button on the side of it for 20–25 seconds while it’s plugged in. If you have tried this step and still have the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.