Chime Pro unable to connect to TP Link router

My chime pro 2 worked fined for 10 months or so, and then 2 weeks ago it disconnected from the router, despite no network changes by me. I tried resetting etc but that didn’t work, so ring support sent out a replacement, which had the same issue. The whole time all my other devices including my ring doorbell worked fine.

Speaking again to support they said it was a known new issue with Chimes being unable to connect to TP Link routers and it would be fixed within a few days.

Are there any updates on this, as 2 weeks later it still won’t connect. Currently stuck with a £50 chime that for 3 months only sometimes rang, and now won’t connect at all! Why do ring keep breaking these things?? I don’t want to have to keep my phone on me and unsilenced just to be able to hear the doorbell ring!

Hi @user21614. Since you already contacted our support team, they likely walked you through all applicable troubleshooting steps for this issue. If you’re not sure, the applicable troubleshooting steps would be the following:

  • Ensure you are using the correct wifi password for your network. Sometimes this can be autofilled with the incorrect password depending on what information your phone has saved.
  • Try moving the Chime Pro to a different location in the house and attempt the setup process there.

If you’ve already completed these steps when you contacted support, you do not need to do anything further. You should receive an email from our support team when the issue is resolved, and we will post an update on the Community at that time. Thanks for your patience as our team works on resolving this!

Hi @Caitlyn_Ring,

Yep went through those already. Was hoping it might be possible to get an update on when this might be fixed? I’ve already missed several deliveries because I do not get notified when the doorbell goes off unless my phone is on and unsilenced.

@Caitlyn_Ring,

Is it possible to get any more updates about this issue with TP Link? Phone support have said they can’t do anything and I just need to wait for it to be fixed, but its been 6 weeks now and it is still very inconvenient not being able to actually know when the doorbell is pressed unless I keep my phone on me and on loud at all times.

I was able to connect to the internet via my laptops mobile hotspot, and after a while it picked up a firmware update that fixed this issue. Not sure when the firmware update was pushed but I tried to do the same thing last week and it didn’t work. Either way if anyone elses is bricked like mine hopefully that should fix it!

1 Like