Chime Pro Not Completing Set Up

I am attempting to set up my ChimePro. When I go into my Wi-Fi settings, I tap on the ChimePro Network. I am now connected (no Internet access). Which is all good. However, that is where the process stops. My options are either to sit and wait. Or cancel the set up. I get to the same point after I have held the reset button on the ChimePro for 15 seconds and set up from there. Does anyone have any suggestions?

1 Like

We have the exact same problem, we’re going round and round in circles. I am looking forward to seeing what response you get!

1 Like

Hey neighbors! When setting up the Chime Pro, you will need to connect to the Ring AP for the Chime Pro during the setup first, and then it will prompt you to select your home wifi network for the Chime Pro to connect to. It sounds like you may be getting caught up in the Ring AP bit? If you can, please go through the setup on the Chime Pro again, and then it asks you to connect to the Ring AP, let me know if you can connect through that, or go into your wifi settings on your phone and manually connect to the Ring AP in there. Please note that connecting to a Chime Pro Network will be what other Ring devices (such as a Doorbell or Camera) will do after the Chime Pro is fully set up. :slight_smile:

Thanks for the feedback. My issue continues. I’m confused when the steps get to the connecting to wifi section. You state that I should connect/click on my Personal Home WiFi Network. The Ring App states that I should connect/click on the Ring Network that appears in my Available WiFi Networks. So which is it? Also, when the ChimePro is in set up mode, TWO Ring WiFi Networks appear. One is my Ring ChimePro. The other is named Ring Setup 73. So, which of the 3 WiFi Networks do I connect to? And what should happen after it states that I’m connected?

@CdnFlyersFan You will need to connect to the Ring Setup 72 if you are stuck in the bluetooth setup or connecting to the Ring AP. While the Chime Pro Network is there, it says no internet access because the network has not been fully established. The Chime Pro Network will be established and accessible for the Ring Doorbells and Cams once this setup is complete through the Ring app. Therefore, once you have connected to the Ring Setup 72, it will then promote you to connect to your home network, which will be whatever you home wifi network is named. :slight_smile:

You will need to connect to the Ring Setup 72 It’s “73”. Please pay attention to the details. if you are stuck in the bluetooth When did Bluetooth come into the equation? setup or connecting to the Ring AP. While the Chime Pro Network is there, it says no internet access because the network has not been fully established. WTF? Please see attachment. The Chime Pro Network will be established and accessible for the Ring Doorbells and Cams once this setup is complete through the Ring app. No S#!T! Therefore, once you have connected to the Ring Setup 72, It’s 73. And it also states “Connected No Internet Access” it will then promote you to connect to your home network, which will be whatever you home wifi network is named. Chelsea, I appreciate your attempt to resolve my issue. But you are just regurgitating what I have already attempted. Can you Please answer two questions for me? 1) Which WiFi network network do I connect to when prompted?

2) Why does nothing happen when I conect to to the WiFi Network I connect to when prompted?

1 Like

Have you had any success mrsdoddy? Chelsea is talking in circles with no useful info.

@CdnFlyersFan Thanks for getting back to me! I apologize for my confusing response, as it is indeed not accurate. I was under the assumption that you were still in the pairing part of the setup. During this part, it will normally connect to the bluetooth on your phone, then the Ring AP (Ring Setup 73, my apologizes for the typo and typing it as 72). It seems you have already gotten past this part from your most recent screenshot, so thank you for that! During this part of the setup, you will be selecting the network from the list in the previous screenshot that states “Chime Pro 32EDA2.” Once you have select that network, you will tab back into your Ring app where it should take you through the final steps of the setup process.

In the event that you have been selecting the network I have provided, we may need to preform the additional troubleshooting steps to help get it connected. When setting up the Chime Pro, please try a set up near you router. Once it is connected, fully set up in the app, and firmware update is complete, you can unplug the Chime Pro and move it around your home as you desire. In addition, you can try rebooting the Chime Pro before you try the set up again, as this reboot may help the network join and connect during setup.

For the reboot, if you look on the side of the Chime Pro you will either see a small pinhole or a button. If it is a pinhole, grab a paper clip or something small enough to fit. Ensure the Chime Pro is plugged in, and while plugged in, press and hold down the button (or paperclip in the hole) for 30 seconds. After this, the device will reset for the next minute, which I would say try the setup after that time has passed! Let me know how this goes. :slight_smile:

I attempted Chime Pro setup after rebooting the device. Here are the steps I completed.

Opened thr Ring App that is on my Android phone>Clicked on Set Up a Device>Chimes> Scan Code on ChimePro>Chose an outlet very close to my router>Named the Chime Pro>

Plugged the ChimePro into the outlet>Received “Welcome To Ring” message from ChimePro>Wait for the light on ChimePro to pulse slowly>Waited for phone to “find” the ChimePro>Received the message “ChimePro is in set up mode” from the ChimePro>Is the light on the front of your Chime Pro pulsing slowly>yes>Go to WiFi Settings>Click on ChimePro-32EDA2>Connected (no internet access)>Wait a couple of minutes>Tap back one screen>I am brought back to "The pulsing light on the front of your ChimePro means it is ready to connect with the Ring app>Then it advances to "Is the light on the front of your ChimePro Pulsing Slowly>Yes>Go to WiFi Settings>And the vicious cycle begins.

It doesn’t matter if I do the 5 second reset, the 30 second reboot or uninstall then reinstall the Ring app. Once I click on the ChimePro-32EDA2 WiFi Network, the device installation process stalls out. Do you have any other suggestions? Is it possible that the software in my ChimePro is outdated? Would a ChimePro (2nd Generation) solve my issue?

This issue is beginning to concern me. While the ChimePro is not doing it’s job, my floddlight cam is also out of service. FYI.

I’m having the same issue can’t get past the selecting the chime network and then being asked to select it again - it’s quite frustrating

1 Like

I was waiting for Chelsea’s reply. But it appears she has either given up on us, or is on days off, and decided not to pass our concerns along to a co-worker. Thanks for your concern Chelsea.

UPDATE! I managed to resolve my own issue. Here is what I did. I hope it helps others with the same issue.

  1. I am using and Android phone. So, for iPhone users, Sorry. I got nothing.

  2. Check what version of Android you are running. My personal phone is running v.10. No matter what I did. I could not set up my ChimePro.

  3. I checked out another Android phone that is in my home. It was running v.9. I decided to use that phone for the ChimePro set up attempt.

  4. I went into the Ring app.>Set up new device>Followed the on screen prompts. My ChimePro was set up quickly and easily.

Maybe I got lucky. But I’m assuming that the software in the ChimePro is dated and not compatible with Android 10. Is that why Ring has released a ChimePro Gen2?

Lastly, here is a bit more advice to help with the set up.

  1. If possible, set up in a dark room. The littlest bit of light made it alsmost impossible to see the flashing blue light on the ChimePro.

  2. When I was prompted to go into WiFi settings, you will see a ChimePro network, and possibly a Ring Setup network. Ignore them and click on your personal home network. (If I’m not mistaken, I believe that’s what the directions state.)

Good Luck People. I hope this helps.


I had this same issue (The chime pro connects to my wifi but not to the internet.) and eventually ended up solving it for myself. I followed all the recommended items, resetting modem, router, factory resetting chime. Called into support, uninstalled and reinstalled the Ring app, disabled bluetooth and walked through everything everything I’d already done, but you know, it may work this time. On the 5th(ish) time through things my cell dropped. So while I was waiting for them to call me back I started digging and found you can statically assign an IP during the WiFi setup process.

For users comfortable with making changes in your routers… The following steps should take care of it.

1.) Start with the Chime unplugged from the wall.

2.) On your router, add a reservation and IP with the MAC on the bottom of your chime pro.

3.) Disable Bluetooth on your phone.

4.) Open the ring app.

5.) Plug in the chime.

6.) Start the device setup process. When it wants to scan it skip this since you’ve probably done it 10 times already.

7.) Continue through,deny access to bluetooth.

8.) When it wants to connect to wifi tell it not to connect to the wifi it asks you about. Even if there is only one wifi available and it is yours. We want to manually force settings.

9.) Select your wifi then Advanced Options.

10.) Select Static IP.

11.) Enter ALL of the information it asks for even if it seems to be autopopulated, delete what is there and re-enter it.

12.) Now it should connect almost instantly.


Hi neighbors! My apologizes while I was away, and that another moderator could not get to you in this time. As we are a neighbor to neighbor support forum, you may also not see responses from us on the weekends. I greatly apologize for any delay this causes, and we encourage reaching out to support if you are in a urgent time of need for it.

@CdnFlyersFan I’m so happy to hear you were able to follow through with those steps to get it up and running, and nice job pinpointing why it wasn’t working at first! I will make sure to get this feedback and experience over to the appropriate teams to see if we can have this addressed for the future and not affect other neighbors. This is very valuable information and I cannot thank you enough for it!

@Sciurus Nice job with outlining these steps and giving it the network settings change a try! It’s great to cover all bases, including network settings, to ensure that you have isolated the concern. This is a great things for neighbors to try out if they run into this, so thank you for detailing this out for other neighbors that may come to this thread. :slight_smile:

THANK YOU! I’m an android user too, and like you my v10 phone failed to progress through the install process. I took your advice, fired up my old Android phone v9.x, turned on wifi, downloaded the ring app, and the installation went through to completion. Need to be a little patient as it updates the firmware, but followed the steps and it completed. I was getting tired of using it just as a night light, so thank you for this tip!


Thanks for the info. Your message brought a tear to my eye. LOL. Hopefully this too is acknowledged by the Ring Team and the bugs get worked out. Enjoy your Chime Pro!


Thank you so much for this info. I was having the same pain and using the static IP method worked.

1 Like

I’m trying to set up a Chime-Pro, but it keeps failing. The Chime says that it’s connected to the WiFi, but not the internet. The Ring App on my phone says “Your phone has a poor connection. Seek out better signal or connect to WiFi.” It is connected to WiFi, reports a full three bars of signal, and no other apps have any difficulty communicatng to the internet. Are you having server problems?

I had this issue where I was going in circles in terms of Ring set up for the Chime.

After much research and Youtube videos, I came across one of the post here stating that he fixed this issue by going to a different Android.

I was using Galaxy S20. I tried Pixel, and I was stuck on the same steps.

I tried it on iPad Mini, and it worked. One of the screen did not fully populate the menu on both of the Android, but in iPad, the screen showed with two buttons.

That being said, try different version of Ring Apps. I am sure it’s a bug on Android.

Please read my post from 05-09-2020 08:39 AM in this thread. Don’t make this fix more difficult than it needs to be.