Chime Pro as seperate device in 2.4 and 5gHz using eero

I use eero for my wifi. About a month ago eero started showing my Chime Pro as 2 separate devices each with a unique MAC address with one being the 2.5gHZ and the other the 5gHz. For some reason it stayed connected only to the 2.4ghz signal. I reset it and now it stays on 5Ghz signal but seems like it is trying to switch at times to the 2.4 ghz. It intermittently shows offline as both a 2.4 and 5 device then reconnects after a minute back to 5gHz only. It is also emitting the temporary wifi connect signal as I see it in listed wifi networks on a PC program I use to check wifi networks in my neighborhood. Rebooted eero and restarted chime pro several times with same results. I think my chime pro is defective.

Why would the Chime Pro show as a separate device for each speed? It never used to. I manually changed the name to match the connection used by each MAC address.Thanks

Hello @Jackietools ,

Yes, your Ring Chime Pro is both capable of using either the 2.4 GHz or 5 GHz Wi-Fi bands (like the Ring Video Doorbell Pro). Generally, Ring products do better on the 2.4 GHz band because the longer Wi-Fi range is better through walls. Although 5 GHz band is faster, physical obstructions can severe limit its range.

But Ring devices that can use 5 GHz tend to be “5 GHz Channel picky.” Most routers use the default AUTO mode to hop between Wi-Fi channels, searching for the least interference channel from other Wi-Fi routers (like your neighbor’s). If your router hops above the 5 GHz Channel 48, then Ring devices often will drop off-line. Your router is most likely on AUTO and probably your Chime Pro tends to fall offline and then jump back to 2.4 GHz automatically whenever your router does hop higher than channel 48 in the 5 GHz band.

Ring devices capable of using 5 GHz work best with manually fixed (off AUTO) with these 4 channels: Ch36, Ch40, Ch 44, and Ch48. You should consider removing the AUTO on your 5 GHz band (check website of your router provider, YouTube, etc. on how to access your router’s configuration) and use a Wi-Fi Analyzer to pick a manual fixed channel from these 4 channels choices only.

Here’s a link that explains Ring with 5 GHz Wi-Fi channels:

I hope this additional info is helpful to you. :grin:


I’m using the Eero WiFi and cannot control what band a device connects to if it is both 2.4 and 5 capable. If I am correct it can only be connected to one or the other, it cannot be connected to both 2.4 and 5 at the same time? I just restarted my chime pro and it temporarily showed it connected to both bands but then reverted back to 5G. Eero has a beta feature called Band Steering which states’ Improves performance by encouraging capable devices to connect to 5G". Maybe I should disable that and check performance?

Thanks for your help. Much appreciated.

1 Like

Hello @Jackietools ,

Ah, your Eero has a beta feature to try to push everything capable to the 5 GHz network? Oh, at least that is good that it is trying to reduce congestion on the 2.4 GHz, because Ring 2.4 GHz cameras don’t perform well when competing for 2.4 GHz bandwidth when they are streaming high-data video & audio.

Yeah, as I stated in the link above, my router was initially configured the same way too as your Eero (with just a single SSID for both Wi-Fi bands). But my router allowed me to split each band into two different SSID names, giving me control of which of my Wi-Fi devices I wanted on which band. I know very little about the Eero system (but have read online people successfully splitting their bands with Tech Support or with using the “Guest” SSID). And I also changed from AUTO (channel hopping) to a MANUAL Channel of my choosing. I guess that kind of makes me a control freak, LOL. :wink:

But with separate SSIDs, I only ‘told’ my Ring Chime Pro the 2.4 GHz SSID and password, so it has no choice but to remain on that band. Your Chime Pro and Wi-Fi router can decide “on their own” with your current Eero’s configuration.

So I’m guessing that initially, with your beta “Band Steering” enabled, your Chime Pro connects to both bands, but as soon as data starts flowing to the Chime Pro it should revert to a single band use. And then if the AUTO function hops your 5 GHz above Ch48, then your "5 GHz Channel Picky "Chime probably goes off-line from the 5 GHz band and jumps to 2.4 GHz. This is most likely why you are observing this unusual behavior.

Lots of personal preferences here. I hope this information is useful to you. :grin:


Thanks for all your help