Chime Pro (2nd Generation) - Setup Failure - Looping through Connection Setup (Android)

I recently purchased Chime Pro (2nd Generation) and I’m not able to connect the device to my home network using my samsung galaxy s8 android phone. The app asks me to connect to chime pro wifi but everytime I select the “ring” in the list of wifi names, it circles back to “connecting” to chime pro screen. Is there a setting in samsung galaxy s8 that needs to be enabled or disabled to allow me to get to the next screen in the setup after I connect directly to chime pro via wifi?

I was able to setup the same chime pro using Apple iPhone without any issues.

Information on my android phone:

Ring App (Android) version: 3.27.0

Phone Brand: Samsung

Phone Model: Galaxy S8

Phone Model Number: SM-G950U1

One UI version: 1

Android version: 9

Android Build number: PPR1.180610.011.G950U1UES7DTC1

Message says connected to WiFi but not to internet. Then doesn’t say what do do?

Hey neighbors! When connecting the Chime Pro to your Ring app, it needs to connect to the Ring Setup network first, before connecting to your home wifi network. It sounds like your phone was failing to connect to this Ring Setup Network, or maybe it was listed as “Ring AP.” Most neighbors have found that disabling any previously connected bluetooth devices can help with this concern, but there may be a restriction the phone itself that is not letting you connect to this network, as some will find the temporary connection to this network to not be “secure.” At that time, if disabling bluetooth devices does not help, it’s best to try a setup on another device as you ended up doing! :slight_smile:

You are not the only one who has experienced this issue. I too bought a Chime and ran into issues with SETUP not completing after my Samsung S10 had made a connection to RING SETUP network. I rang support and they took me through the usual reset the device etc.

They sent me a Chime Pro and I tried to set that up, same problem SETUP APP would not proceed after connecting to RING network. There seems to be something in the Android APP\OS which is preventing the app from proceeding further.

I am an IT guy so of course I went through trying different phones. 2 x Android S10 same issue. Borrowed my neighbours Apple Phone and followed exact same steps, worked first time.

So if anyone from RING R&D is reading this, you need to test Android App for this issue.

It has cost you money to send me a replacement when that probably was not necessary. It has cost me a lot of time and frustration with your Chime product.

I’ve had this issue before. If you go into settings, wifi, then the 3 dots, advanced. Make sure you turn off the setting for use data if wifi can’t find internet. It switches to data when connected to the Ring since it can’t find the internet.

Thanks for that, I’m sure I turned off that but if I need to set it up again for any reason I will check that setting. The Ring app should have that as a key piece of advise in their app to avoid these issues. Support did not ask me to check that either.

The problem is that, there’s so many manufacturers, models, Android versions it would make your head spin trying to figure out why something doesn’t work.
Here’s a good article if your having problems with notifications. Followed by the brands that cause the issues and fixes.

Late to the party, but for all others reading.

USE AN IPHONE TO SET IT UP!!! 1 minute and voila.

I tried several android phones, reset wifi, set wifi to 2.4Ghz, got sent a new Chime. Done all suggested things in other forums as well. Nothing.

A friend drops by and I ask to use her phone. BAM. done.