Chime Pro 2 Red Light Flashing

Looking for some help if possible please…

My doorbell and Chime Pro 2 was all working fine until yesterday, i rebooted my Internet, everything connected back up all fine besides the Chime.

It was just flashing blue, i Googled the possible issue, tried to reconnect with my WiFi but no luck.

I factory reset the Chime and deleted it from my devices on the Ring app so it was a fresh install.

I get to the point where i try and connect to my WiFi after entering my password, it gets to arpund 70/80% and says “WiFi connected but no Internet” then just starts flashing a red ring.

I did a fresh factory install on my Ring camera and set it up exactly as the Chime on the same network and password, no problem but the Chime just won’t connect at all.

Any ideas please ?


Hi @MightyMaggy. We have some troubleshooting steps for when the setup process fails here. That article is intended for Ring Security Cameras and Doorbells, but some suggestions may still be helpful. If you have a dual-band router, creating a guest network with only the 2.4GHz network is a good troubleshooting step to try as well.

If this issue persists after trying these troubleshooting steps, please give our support team a call at one of the numbers available here for further assistance. You can find the hours of operation for our support team here.

Hi Caitlyn…

Tried your responses, but nothing worked.

After doing a bit more digging around, i found a thread about how the Chime Pro can’t have a high IP address ending.

Mine was ending in .208 so when connecting via my phone in the setup, i changed it to a static IP to end in .28 and it connected straight away.

Seems to be an issue with Ring that probably needs looking at.