Chime not connecting to wifi

Hi All. I just bought a chime to connect to my ring doorbell. The chime won’t connect to my home wifi. I have tried to setting the chime up close to my router, close to the doorbell and then also removed the doorbell and had that close to the router and chime. Still doesn’t connect. I have also turned off mobile data on my iPhone.
Please help!

2 Likes

Hey there, @Mwad! If you are still unable to connect your Chime Pro to wifi even near the router, it may be best to reach out to support at 1-800-656-1918 so they can look into this for you. This will ensure a quick and easy resolution for you!

1 Like

Hi Chelsea_Ring,

I also have this issue with my chime. I have also tried all the things Mwad did which is what everyone on the web says to do: place it close (next) to the doorbell, place it close (next) to the router, try it 63 times to see if it eventually will connect, all to no avail, the app still comes up with “setup didn’t complete”. I see you have suggested ringing support (I will find number for my country), but are you able to shed some light on to what they are likely to suggest??

2 Likes

Same problem! After talking with Ring support and going through all of their troubleshooting steps, they sent me a new chime which arrived today. It behaves the exact same way - fails to connect to our home wifi. Very frustrating. I don’t know how to proceed from here.

2 Likes

Same issue, tried connecting Chime nearer router and right next to doorbell and it will not find the WIFI network. Very frustrating.

RING - Is there any resolution to this problem that lots of people are having.

2 Likes

Exactly! Why can’t they post SOMEthing since SO many have the EXACT same problem!!? It’s obviously not US causing it & we’ve lost HOURS if not DAYS of coverage & are AT RISK!!

How are you at risk? I mean really… You have alerts by phone right now. And most people have no issues. You need to reach out to customer service for support. This is mainly a Ring user to Ring user site. The Ring agents here will tell you to try the.basics and then tell you to call them.

Same problem here… I m going to cancel my chime. So disapointed… and no solution, read a lot and impossible to connect.

We were finally able to get ours to work. After two hours on the phone with Ring technical support, we were finally escalated to a level 2 support technician (this is a key step, so keep asking to be escalated). She was very helpful in troubleshooting. I am not certain which of these things fixed the problem (and it might have been a combination of all of them) but the issues were related to:

  1. our main network is 5G which (might have been) too much for the chime. So we created a ring subnetwork set at 2.4G, which it liked better.

  2. make sure your network name does not have any special characters in it, and

  3. make sure the network login requires a password (we had first made the internal ring network not need a password since it was a subnetwork of our main one, but the tech said the chime needed to have a password to work).

I am not exactly sure which one of these steps fixed it, but the combination of these steps allowed our chimes to connect. Apparently there are different levels of firmware out there for the various chimes, and some are more picky than others. Good luck!

1 Like

I did these changes and still not working. All ring products are connected to my wifi but still impossible for the chime… I don’t understand why

My call to 3rd level support implied that the network name that you’re trying to connect to cannot have any special characters in it, everything must be alphanumeric. Not sure about passwords. Will try this tomorrow.

If it works, then you’ll probably have to reenroll anything else you have connected to that network. Huge - HUGE - PITA, at least for me. Amusingly, the Ring doorbell has no issues with any network with a special character (well, at least the special characters I have…).

Hi,

Thank you but it’s not my case… My network only uses alphanumeric caracters (letters or numbers).

I’ve tried to connect the chime close to the doorbell, close to the router… and nothing works… and of course all my ring products are working (doorbell, bridge, smartlights spot)…

It’s weird that a lot of person have the same trouble… I probably sure there is a trouble with their app…

5 Likes

I tried all the things to get the chime to connect to WIFI. none of them worked. it turned out that I needed to ensure the wifi network was password protected. as soon as I made my wifi secure, the chime connected no problem and the app asked for the network password. Once the chime is working, you may have to update the wifi settings for the doorbell to use the password too.

2 Likes

When chimes pro was set up I was asked to give a password, is this the password I use when chimes is connecting to Wi-fi or do I use the modem password, also if either passwords don’t work how can I proceed?

Same here. Just setup the entire Ring alarm system this weekend complete with Ring’s Retrofit connector for my hard wired sensors. All of that was super simple. Added a Ring Chime today ( just bought from Amazon) and it will_not_connect to my 2.4 WiFi. I’ve tried at least a dozen times. Fails. I’ve read everyone’s super helpful comments and I’m not too different from any of those situations. The only thing I can see is perhaps a missed step. Add device in app, scan QR code, THEN plug in Chime device and follow prompts.
It ‘looks’ like the device add in the app is simply timing out. Pretty stumped here. Might buy another and try that.
Feedback to Ring if they are listening. Don’t just move onto the Chime pro model and deprecate the Chime. It’s smaller, more subtle for hallways and if anyone bought an alarm kit to use with this they got a signal booster included. Plus the chime pro is just well not nice looking ( this forum blocked this post with the word u_gly In it lol) with 2 antennas. I’d hate to have to use that.
Anyone know of a firmware version that works and a way to flash these to the most current ?

Update, I have resolved the issue. Here are some points that I learned that might help others.

  1. Factory reset the Chime - little button on side, hold for 5sec. They say use a pin or paperclip but I just used a finger.

  2. Unplug it, leave it unplugged

  3. In app select add device, blah blah get to Chime, scan QR code

  4. Plug in Chime, let it go from flashing quickly on the logo light to flashing slowly. this was the bit I wasnt doing, I think the Chime was on and looking for th eRing network services before I told the app about it, some form of timer/timeout happened, causing failure to complete device add.

  5. If the App throws the 'the last time you tried to add this Chime you used this network < insert_your_wifi_name> - Do you want to use it again? ’ - Choose No and then choose your network again from the list. This ensures you enter the PWD correctly

  6. This worked for me, I had already ordered a new Chime as I thought I had a DOA.

Its unfortunate you cannot see the device details until the device is added in your app, but the specs show a firmware of 1.1.27 . Once i got the Chime to see my network, got it added correctly there were some updates pushed to it, so I am not sure this was the original firmware that shipped on the device.

Anyways, working now, pretty cool little device, customizable ring noises etc, worth installing. Process to get it registered wasnt fun.

28 Likes

Finally fixed!

after some long hours, theirmphone support was helpful… we eventually got the chime to connect to my phone hotspot, support forced a firmware update to 1.2.9, then we did a ‘change wifi’ and it finally connected to my google nest WiFi mesh.
just thought I’d share that potential solution…

1 Like

That last one may have to be my last attempt. Phone hotspot:(
I have 2 other chimes, connected fine.
The third one won’t. No matter where I put it or how many times I reset it.

Removing special character - & - from the name of the wifi network did the trick.

1 Like

The chime is yet another annoying product by Ring. It has nothing to do with special characters or whether you connect it ‘right next to your hub’. I have owned one for more than two years and its a fickle timewasting thing. It may take many times before it connects mysteriously for no reasons. You just need to keep trying and trying again. Then it will work fine right up until you have a power cut or need to reset your router. Then you will lose more precious time trying to manually reconnect it because it will have fallen off the network and cannot get back on…oh and if you have even more time to waste try to then active the chime on your Alexa and Google Home devices as I did because that also takes time and doesn’t work…there was a time when you could just stick some batteries in a push device and it would work the first time, every time and not be this complex…if Ring can’t make using their products as easy as that then the negatives start outweighing the positives…

6 Likes