Chime blinking blue word "ring"

The word “ring” is blinking blue at the bottom of the wireless plug-in chime. The rapid blinking continues day after day. The chime is connected to two Ring Pro doorbells, and each doorbell properly rings the chime. If I unplug the chime, and replug it in, the word “ring” changes from blinking to solid blue. But after a day or so, it is blinking once again.

Should this be blinking? Should something be done so that the illumination is only continuous blue?

Hi @JimNorthWales! The blue blinking is usually an indicator that the Chime is in setup mode, or attempting to connect to the network. The best first step will be to ensure this Chime is close, or within reasonable range, to your wifi router. Please also ensure it is not placed somewhere with high interference, such as in a kitchen or garage.

Once sufficient signal is confirmed, the next best step will be to ensure the plug outlet is securely holding the Chime, and that it is not loose or hanging. I hope this helps! :slight_smile:

We have exactly the same problem - the Ring Chime is flashing the blue Ring. The only difference is that our Ring Chime is connected to a single battery Ring Doorbell.

The Ring Chime is firmly in its power socket, which is on an internal wall on one side of the door with the Ring Battery Doorbell on an external wall on the other side of the door. We have BT Whole Home Wi-Fi discs to extend the Wi-Fi signal and the Ring Chime is closer to the nearest BT Whole Home Wi-Fi disc than the Ring Battery Doorbell. The Ring Battery Doorbell shows RSSI-61 at worst - at best, it is in the low 50s - so at all times, it is sufficient.

Interestingly, our wired Ring Doorbell, which uses the house bell circuit has a fairly consistent RSSI-65 although it is much closer to the Base BT Whole Home Wi-Fi disc. It has started showing black video sections in the mobile app timeline. The History section of the Ring PC app shows no entries for the time periods of these black sections in the mobile app timeline.

Basically, we have two (possibly three - definitely the Ring Chime and the wired Ring Doorbell and, possibly, the Battery Ring Doorbell) Ring devices showing issues that could be related to Wi-Fi. However, Wi-Fi provision is as good as possible with five BT Whole Home Discs positioned around a relatively small three-bedroomed, detached, mid-1970s built, house with no other Wi-Fi devices indicated any Wi-Fi issues. ALL Ring devices worked in this configuration for some time but have now started to show failure symptoms.

What do you suggest be done to analyse these issues further, please?

Regards

Joe.

Hi @JRJSmith. We have this Help Center article here that has some helpful tips and tricks for Black Video. If this doesn’t seem to provide any improvement, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.I hope this helps!