Chime (2 Gen) WPA security

Almost all Routers have WPA2 - aes security and yet Chime (2 Gen) only uses WPA so you have to lower the secuurity level to enable to add the device.

Is there a new download to enable add the various levels of security

I’m only using WPA2 on my router and my Chime has no issues connecting to it. WPA is not an option on my router.
Not sure why you’re having issues getting it connected with WPA2.

Sky and Now routers defaullt are WPA2 - AES are the default

Chime is WPA… which will not connect

You have to change it to WPA/WPA2 mixed mode (TKIP) which it then connects… via WPA

WPA is not enabled on my router and my Chime connects via WPA2. So your statement that Chime is only WPA is false.

Do you have a Hidden Network? My Network is Hidden… SSID . Tighter security… (All networks at work are set hidden SSID’s as well)

So I have to type my Network Name in… then you have to select the the security the only options are WEP (Never use–Bad) or WPA then you type in the password.

WPA2-AES is Tightest… And want to actually use this… hence the question about an update…

But I believe WPA2-PSK allows WPA to be accessed as well

Thankfully no, I don’t have a “hidden” SSID as they are pointless and add no extra security to a WiFi setup.

Good luck!