Charging Station


I recently purchased a Ring Charging Station (for charging 2 x quick release battery packs) it’s new and cost £25.99 here in the UK

Unfortunately the batteries will never fully charge using it, only 91% roughly, sometimes less!

We have had a Ring doorbell since they first appeared in the UK and have added cameras along the way, never had an issue with charging batteries before. I usually charge my batteries with a cable and plug in usb charger in the wall socket and always get 100% charge from them, but I thought that the charging station was a good idea as it was quicker and could hold 2 batteries at once.

I have spoken with Ring CS and they have sent a replacement out, it did cause grief as the product/box DO NOT have serial numbers on them and I was on the phone for over 90 minutes! (Got cut off once)

Now I did say to the representatives at Ring when I was on the phone that I definitely think it’s a design fault and not a problem with my charger as the batteries just literally sit in the charger, they DO NOT click in place or have anything holding them in place, so the batteries/charger stop making contact!

The replacement is as I guessed just the same, first battery got 91% & second got 82% ! I did try it with an elastic band around (Not what I really want) but just to see if the force holding the batteries in place with the charging station contact point made any difference, well it didn’t!! 81% …. Absolutely awful (One battery was also brand new! I then plugged them into the wall with a cable and got 100% from all!)

So if you have purchased one please report your charging success or failure

If Ring read this then please get your Research & development team to grab one of these off the shelf, put 2 batteries in and see what charge you get, I can guarantee it will not be 100%

I will be getting a refund!

Hi @Koje. Are you using the included USB cable and AC plug when using the Charging Station? It’s not recommended to use a different USB cable or AC plug, as this can cause the batteries to take longer to charge. It should take about 4 to 5 hours to fully charge one battery on the Charging Station, and there should be an indicator light that lets you know when the batteries are fully charged. If you haven’t already, I would also suggest trying a different power outlet to see how the batteries charge. Also, which Ring devices are you putting these batteries into in order to check the battery percentage after charging them?


Yes I am using the supplied USB cable and plug, yes i have tried them in different sockets
If you haven’t seen or used the charging station it actually has 4 little white LEDs for indicating the charge status. These lights will indicate a fully charged battery by 4 solid LEDs, sometimes it stops before hand and you have to reseat the battery but if you get 4 solid lights I can guarantee you it will not have a 100% charge in the battery despite what the lights say! Yes it should take less time than a USB wall charger but the difference is that the USB gives 100% and the charging station never! The quick release batteries have been used in Ring doorbell 2, stick up cam 2nd gen & 3rd gen and spotlight cam! all report they are under charged! Just spoken with your CS and they are sending out a stock A charging station to try!

@Koje Thanks for sharing that information. Contacting support and receiving a replacement is likely the best stop, as there is not much troubleshooting you could do for the Charging Station itself. Feel free to report back on how the replacement Charging Station works for you. If this concern persists after receiving the replacement, then you will want to follow up with our support team so they can further investigate. :slight_smile:

1 Like

Thank you :+1:

This will be the second replacement but they couldn’t be certain if the first replacement was a refurbished product hence the stock A being sent out.

I will definitely post my findings when it arrives and I have used it on a few batteries

This definitely needs looking into by someone at Ring as it seems a very poor design!

1 Like


So I have received the stock A (3rd) replacement today and put in 2 depleted official Ring batteries after 90 minutes both batteries have stopped charging! Different plug socket used with all the new enclosed cable and plug! Right side stopped with solid LED on just 3 LEDs 93%, left side just one solid LED in the middle 81%!!!

@Koje The Ring Community is a neighbor-to-neighbor forum where we’re able to help with basic troubleshooting assistance, but this concern seems to require more in-depth help that goes beyond what we are able to provide here. If you leave the batteries charging for the recommended duration of about 4-5 hours and they are still not charged, please follow up with our support team since this is a replacement and it’s not working correctly.

The indicator for the left battery means there is a connection issue with the battery. Does the same indicator show up if you swap the battery packs? It’s possible the contact pins on the pack are dirty or damaged. I know you posted above that one of the packs was brand new. How old is the other pack? It’s also possible that the battery packs themselves are faulty. They have two cells inside and if one of the cells fails prematurely then the pack will not operate correctly.

I’ve owned one of these chargers for about a year now and there have been a few instances where the charging stops prior to all four LEDs illuminating, but if I remove the pack and seat it again the charge seems to complete.

1 Like

The other packs are all different ages, all are supplied by Ring but all of them charge with no issues via the supplied USB cable, always 100%. All 3 of the charging stations have been as inconsistent as each other and never ever giving a full charge. The first thing I did was wipe the contacts but it didn’t make any difference at all. That indicator came up with different batteries on different charging stations. all together I have 8 different official batteries but NONE of the charging stations have charged them to the full 100%! I have often reinserted the batteries when they have stopped charging part way through but this surely shouldn’t be necessary and even when they show 4 solid LEDs they are still not at 100%

Maybe check the charge % next time and if you could comment on here I would really appreciate it


Correct which is why I would really appreciate it if others could comment their % after charging as I am sure people are just putting their batteries back in without checking that it is really fully charged and why I have asked Ring to check this as well

Four calls and chats with Ring CS has unfortunately gone through the very limited trouble shooting available on such a simple accessory hence why they just keep replacing them

I can verify that each of my six battery packs always indicate 100% on the device after I reinstall them.

1 Like

Just had a look at all the reviews on Amazon and not surprised by the amount of people with the exact same issue!

Spoken with the absolutely great Ring CS and just got a refund