Can't transfer ownership


My dad just gave me his ring doorbell but I am having an issue setting it up.

When I tried it said he needed to disconnect the device from his account.

I tried to help him through the process (He is not very tech savy) but he was not able to do it. When we logged into the account he thought it was registered under there was no device visible.

Any idea what I can do?

Hi @gwpt! Check out this help center article containing steps for Changing Ownership. Being able to check the email associated with the accounts will be key to releasing/ obtaining ownership. If this process is not successful after giving some time for the change to process, our support team will be happy to assist further. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. I hope this helps! :slight_smile:

1 Like