Can't connect ring chime

Hi I’m new here I’m from UK. I have a ring door bell gen 2 and just bought ring chime but can’t connect to ring network always says connected but not to Internet I tried everything I can’t go any further it just ask if I want to cancel set up. Help please thank you

Hi @Mrspitt50. Are you unable to set up the Doorbell 2 or the Ring Chime? Try setting it up on a different phone or tablet if you have one available and see if you can successfully complete the setup. You can also try resetting the Doorbell or Chime before attempting to set it up again. On the Doorbell, you’ll want to hold down the setup button for at least 20 seconds to reset it. For the Chime, you’ll want to hold down the reset button on the side for 20 seconds to complete a reset. Let me know how that works for you! :slight_smile:

I purchased a chime last week and then had at least 20 attempts to context it to my WiFi. No Luck. Every time I got the message Hmmmm… something has gone wrong with your setup. I tried everything that was suggested, tried without scanning using the PIN number switched my wifi off three times for 30 seconds, nothing worked. Chime flashed red, then green and then solid red. Reset the chime umpteen times still nothing worked.
I then rang Ring support in the UK and spoke to an agent who was exceedingly helpful and we went through the whole process about three times. Still no connection!
I rang them again the next day and after explaining the whole problem again they decided to send me another chime. It arrived yesterday and the same thing happened - hmmm… something has gone wrong with your setup!!!
I then decided to download the Ring app to my IPad instead of using my Android Samsung phone. IT CONNECTED FIRST TIME​:clap::clap::clap:
Having now read some other people’s problems it would appear there must be a fault in their App for Android.
Buyers beware!’

1 Like