Cannot purchase protect plan

Hello, For some reason I am unable to purchase a Ring protect plan, I have tried everything but whatever link I try it just keeps throwing me back to my dashboard, starting to feel like groundhog day, any ideas or help would be great, thanks in advance.

Forgot to mention I still have 15 days left of the free trial.

Hi @user24677. If you are not able to subscribe to a Protect Plan on, try the following steps:

  • Verify you are set up as the owner of the Ring device. Shared Users are unable to enroll the Ring device in a Protect Plan.

  • Use a different web browser.

  • Try using a different device to go to to subscribe, whether it be another smart phone, tablet, or computer.

  • Disable any active VPNs on your device.

We also have this Help Center article here that guides you through subscribing to a Protect Plan. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

1 Like

Had this same problem a few weeks ago. I think its a website or application problem. It was fixed here in the US. Ring didnt disclose they were having this issue so I kept on getting redirected to main page. Let them know what version of browser and OS you have. Hope this helps!


1 Like

Hi, thank you for the replies, just an update on this problem, it was down to using Edge browser which for some reason caused the problem, I was able to complete a purchase by using Chrome browser, hope this is useful to others.

1 Like