Cannot get Ring Bridge attached to ring system


I have a ring system with doorbell, two other cameras, and alarm system. I am using TP-link Deco mesh router

With one of my android phones, I never got past the “blue light is flashing”.

With another android phone and attached to one of the satelite routers, I can get it to ask about wifi password, but it did not finish registering. I moved the bridge next to the main router and was able to get it “attached”, but then it said it was updating itself and then said it failed.

I had no problems getting any of the other ring devices attached (using the first android phone that did not work at all).

1 Like

I also cannot connect after clicking ‘blue lite blinking…continue’. I have a doorbell2 that installed without issues and is still working so I called support for help and they are sending me another bridge. Ring app is running on my Samsung A10.


I got a second bridge and have the same problem as with the first.

1 Like

I called support with the same problem and he said press reset on the bridge, reinstall the Ring app and go thru the install again. This time it worked.

1 Like

I reinstalled the Ring app and ran the install again. This time it worked.

1 Like

Uninstalled and reinstalled. Then bridge connected seamlessly.

Uninstalled and reinstalled Ring app. Then bridge connected seamlessly. Thank you

1 Like

I had the same issue on three different A19s, via android. Did all the suggested uninstalls, reinstalls etc, nothing work. Setup via iOS and worked like a charm. This needs to be resolved for future setups as it is very frustrating.