Cannot add ring chime to my app

Hi,
I just purchased a chime 2 for my ring 2nd gen. However, i’m trying to add it in to my acooun but is not working. I get up to the point where i connect to the ring wifi and the green light suppose to blink slowly but is not doing it. The green light keep flashing on the same way and the app is keep asking me if is flashing slowly.
I have tried to reset it by holding the buton for 5 sec. But this didn’t help either. Any suggestions?

@Bogdan_d wrote:
Hi,
I just purchased a chime 2 for my ring 2nd gen. However, i’m trying to add it in to my acooun but is not working. I get up to the point where i connect to the ring wifi and the green light suppose to blink slowly but is not doing it. The green light keep flashing on the same way and the app is keep asking me if is flashing slowly.
I have tried to reset it by holding the buton for 5 sec. But this didn’t help either. Any suggestions?

Instead of a normal setup, try a Hard factory reset (press and hold the reset button for 30-seconds and then release). It could take up to a minute for it to reset and then it should start the set-up again.

I have tried that also but still the same. Do you have any other suggestions? Thanks

Hi @Bogdan_d! Despite the LED indicator not reflecting what the Ring app is suggesting in this step, does the setup allow you to proceed anyways? Try completing an entire setup, up until the point in which the Ring app will not allow you to continue. If that happens to be this step, please remove and reinstall the Ring app on your mobile device and try again.

As you’ve already completed a reset, and confirmed there is power via the green light, the setup should be completing as intended. If possible, try completing this setup on a different mobile device entirely. I hope this helps! :slight_smile:

Hi, I also have the same problem. The green light on Chime is not falshing slowly. As suggested above, I tried soft reset, hard factory reset, uninstalled & Installed app, use another mobile for installation but facing the same issue. It get stucked where app ask if the green light is flashing slowly. I tried moving ahead by saying yes, but it get stucked after connecting wifi of ringsetup.
My ring video doorbell 3 is connected to app and working.
What should I do, shall i ask for Chime replacement?

Hi, I also have the same problem. The green light on Chime is not flashing slowly. As suggested above, I tried soft reset, hard factory reset, uninstalled & Installed app, use another mobile for installation but facing the same issue. It get stucked where app ask if the green light is flashing slowly. I tried moving ahead by saying yes, but it get stucked after connecting wifi of ringsetup.
My ring video doorbell 3 is connected to app and working.
What should I do, shall i ask for Chime replacement?

1 Like

Hi @ankitsriva! Excellent job covering all of those steps. You’ve certainly checked everything that we would recommend in the Community. The best next step will be to reach out to our support team for more in-depth troubleshooting. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I created an account here explicitly so that I could document my Steps.

So I came to this thread for the same reason as the OP. I was trying to add the Ring Chime to the App. I had already added the Ring 2 Device to the app with a minimal of fuss.

But when I started to set up the Chime, I had the same looping problem as the op. The app would ask me if the LED is green and blinking slowly when I tapped yes, it’d go to the screen where it just gave you the same message that green led means it’s ready to pair but no interaction. After a minute or so, the app would go back to asking if the Chime led is green and blinking yes or no.

So eventually I called the Customer Service (1 (800) 656-1918). That’s when we realized what the issue was. Due to the Location Service on my phone being turned off, the app was unable to auto connect to ring’s temporary wireless. You have to have Location or GPS service turned on the phone in order for the app to go through the process. When I turned on the GPS and went through the setup steps, it was a breeze. I had it set up in record time. The agent I was connected with was incredibly helpful and friendly.

One thing you have to note since it’s not clarified anywhere. After the Chime has been correctly set up, the LED will be a solid BLUE!!! If you are expecting it to be green then that’not right. Also if the chime is downloading software update then the led will be blinking green and blue alternately. But otherwise under normal operating conditions it will be solid blue.

P.S. - I have an Android phone if it matters.

1 Like

Hey @sdupadhye. Thank you for sharing your experience. This is very useful and I’m sure many will benefit from your findings!