Bug report: Light Scheduler

I just purchased the Outdoor lighting transformer with the bridge, got all the latest updates for the units and the newest app. Upon setting up the custom light scheduler I set the time to AM and it switches back to PM so therefore I cannot have the lights turn on or off in any of the am hours.

1 Like

Hi @catb50 can you please send over a bit more information? Can you please let us know the hours of the schedule you are trying to set so we can try and duplicate it in the office? Also, let us know what phone and app version you are on and whether or not you have tried uninstalling and reinstalling the Ring app. Thank you!

@Jennifer_Ring thanks for the reply the phone I am trying it on is the Samsung Galaxy S10+ I have reinstalled the app version 3.19.2.

When I select am it seems to change it just shows PM like in the screen shot. It is actually set for 12:30am

Thank you! We’lll get this information over to the team asap and be in touch shortly!

Today is 11 dayes later and no report from ring. This is concerning for me as a first time user of the communty group.

Hi, I would like to report an issue with light scheduler on Ring floodlight security camera.

I am living in Washington D.C. area and I have Eastern Time Zone on my iphone.

I set “light turns ON at 6:00 PM” and “light turns OFF at 6:00 AM”.

However, the light has been turned ON at 1:00 PM and turned OFF at 1:00 AM every day since I has set up “light scheduler” feature. I found out in order to make it work right then I had to set “light turns ON at 11:00 PM” and “light turns OFF at 11:00 AM”. That means I have to add 5 more extra hours to my desirable time for the lights to turn ON or OFF.


If you would like the lights to turn ON at 6:00 PM and OFF at 6:00 AM then

you have to set the lights to turn ON at 11:00 PM and OFF at 11:00 AM (by adding 5 more hours forward to desiable time when setting the time for lights to turn ON or OFF on scheduler)

I hope that you will mention or inform this issue to the tech or developer team so they will have a bug fix for it.

Thank you,


I have the same problem. I have a ring floodlight camera and am in the US Central time zone and have worked around it by adjusting the schedule in the app by 6 hours.

Clearly there is a bug where the floodlight camera or the ring Android software client does not properly account for time zone when setting the schedule. Please correct.

Ya I gave up on using any of the ring scheduler, instead just used the Amazon Alexa app and setup routines works much nicer and keeps everything all together in on application. Not sure how that works for the flood light cameras though.