Bridge won’t connect

EMAIL
help@ring.com

I had the same issue when attempting to connect a bridge today and the suppoort rep had me press the small recessed rest btn but this did not fix the connection problem.

Got the bridge today. Was connected to wifi for about 20 min before it lost the connection. Tried everything all day, but cannot get it to connect to wifi. Reset it, restarted my modem and router, start, sat it right next to the router, toggled mobile data, and airplane mode… I cannot get it to work. Any help?

Thank you for this post! After hours of messing with it and no solution from Customer Support, I forced a security app to stop on my S10 and it worked! I also shut off my mobile data during setup.

1 Like

Genius! Thank you for this.

1 Like

What is the name of the app u turned off for bridge to connect?

I tried everything and couldn’t get it to work on my android. Borrowed my wife’s phone (iPhone). Worked first time. Blech.

Hi, neighbors! For those using an android mobile device, here is our help center article about android apps that might conflict with a Ring app. Please also ensure vpn is not enabled. Thank you for working together in this thread, providing many steps for any future neighbors to try. :slight_smile:

For all users, whoever faced the issue of bridge not connecting to WIFI in android phone, please go to your App settings and clear both “cache and storage”. Then login to your app and try to add your bridge.

This really worked for me

6 Likes

This worked. I never tried adding a bridge up until this point. Not sure why anything would be cached or need to be cleared!?!?! Bug?

venkybems’s solution worked! If you’re like me and made it this far through the thread without finding anything that worked, try what they said (going into the settings on your android, selecting the app settings, selecting the ring app, and then clearing the cache and data (it might give you a message saying it will delete all the account info etc. associated with the app, I was afraid this meant I would have to reconnect all of my devices, but really you just have to log back into the app on your phone).) After doing all of this, the ring bridge connected on the first attempt.

2 Likes

Buggy Bridge Connection process (at least with Android Pixel). Very annoying. Thank you for the suggestion of opening phone Settings, Apps, Ring App, and clearing cache & data. That did the trick for me also. (I had previously installed & connected a couple of cameras. Perhaps issue w/ bridge avoidable if one connects the bridge first…). Minus two stars for the smart lights just for the initial two hours of connection effort wasted, although product seems to be working okay now. Thanks again.

1 Like

Hi Everyone, I do data center buildouts for a living and have been around the block a few times setting up corporate networks for the past thirty years. I had an issue setting up my ring lighting bridge as well but here is what worked for me; I hope it helps you out.

Challenge Accepted!!!

My network is a switched 10Gbit 2.4 and 5GHz Ubiquiti setup and I was using a Samsung S20 5G FE for setting up my Ring devices. All went smoothly until setting up the lighting bridge; it would connect to the bridge SSID after power up with the blue light blinking but would go into an endless loop of attempts to connect to my home network and prompt me with the same question after timing out.

I removed and reinstalled the Ring app on my phone - it was recently purchased but I had upgraded and carried over the app and settings from a 2yo Samsung Galaxy S8+ so I thought it could be an issue - this did not work.

Another user suggested clearing the cache but my phone was new so cache was not the issue in this case.

What ultimately ended up being the fix was disabling the following setting on my Android device temporarily during setup:

Go to Settings -> Connections -> WiFi - > Choose the three vertical dots in the upper right corner and select Advanced -> Under Intelligent WiFi, turn OFF “Switch to mobile data”

Once you have this turned off - follow the instructions in your Ring app for adding a device; it should now work so have your WiFi password handy after choosing your wireless network SSID. My bridge updated after connecting so give it a minute or two - there was a message informing me of this which had not appeared in previous attempts.

The failure here was my phone was automagically switching to mobile data because when you attach to the Ring bridge’s SSID without a path to the Internet and this option is enabled, it will go to the cellular network instead of returning to a WiFi connection and allowing your bridge to join the same network.

Good luck and thanks to Eagle328 for pointing me in this direction as well.

1 Like

This worked for me when reinstalling Ring App and clearing cache failed.

1 Like

Same issues - I have a Samsung S20 with Android 11 and the installation would connect and go now further - My other phone is an S8 with Android 9 and I was able to install the Bridge and the lights easily - no problems at all

Thank you SO VERY MUCH!!!
This worked for me after trying almost EVERYTHING.
Again, thank you so much for taking your time and posting this solution :slight_smile:

I had the same issue. I actually had my Bridge connected fine using my Samsung but then I installed a new router. I could not get the Bridge to reconnect. I cleared my cache, but not the data and also reset the Bridge and that did not work. I decided to try my wife’s Iphone… it worked!

  • Maybe if I cleared my Samsung App data when I cleared the cache also that may have worked, but the warning that I would have to redo everything scared me away as I have other devices connected.

Clearing the data and cache worked for me. Struggled for an hour, clear data and cache and was up and running in 5 minutes!! :grinning: :grinning:

1 Like

Data reset (not the clear cache) did the trick for me. Just have to enter your id/password to get back in and it worked. Thanks. On Android (Samsung Galaxy S10+), long press the Ring app icon, app info, Storage, press Clear data.

1 Like

Using my husbands iphone worked for me. I tried to reset the cache, data…turn off data switch settings on my android (samsung). Nothing worked. I used my husbands iphone and the bridge set up with no issue in 5min.

1 Like