Bridge won’t connect

Hi everyone. I just got the Ring system, and so far it’s been great. My app was able to easily find the doorbell 2 and the backyard floodlight cam.

Then I hit a snag. The bridge just won’t connect. It’s plugged in and the blue light does flash. But when the app asks to join the network, it searches and fails.

I’ve tried restarting my router and changing my WiFi from the 5G to the regular connection. Nothing. Any advice?


Hi @Jboland17 ! Can you please confirm you are performing all of the proper steps while setting up your Ring Bridge? You can view the full set up guide here . There is a note in there, which mentions pressing and holding the Bridge set up button (we recommend using a paper clip) in the case the setup mode is not initiating. While the LED indicators you are seeing sounds correct, the setup mode itself might not be joining with the app. Please let us know how this goes!


I called customer service and they helped. Thanks for the response.

1 Like

Thank you for giving our support team the chance to assist, I’m glad you were able to get these concerns resolved! Would you be able to share any details on the solution for neighbors who might experience something similar?

How do you call customer service?

I am having trouble connecting my spotlight to my bridge. Bridge health is very good so I’m

suspecting it’s the wired spotlight

@Zaldy were you able to connect your Spotlight to your Bridge?


Yes, I was able to connect my bridge and floodlight light after I reset my bridge.

Thank you



Zadly, what do you mean after you reset your bridge? Like you did a full reset?


Yes. I did a full reset by pressing the reset button. I can’t recall how long I have to hold down the reset button. I followed the instruction from on how to reset the bridge.

After the full reset, I followed the instruction again to set up the bridge.


1 Like

I have the same problem. I have tried 2 differnt bridge units and will not get past Scanning for available Wi-Fi networks. I have tried resetting bridge by holding down the button for 10 sec. I have tried it with the bridge setting on top of the wi-fi router still not showing any networks. All other ring devices work properly and are connected to the wi-fi. 2 Cameras, doorbell alarm all fine. Bridge just will not connect to wi-fi. Looks like the app connect to the bridge then when it switches to scanning for available networks nothing. Please help before i have to return another one and all the lighting fixures i boaught.

1 Like

You could try to go into your settings at that moment it’s searching and select your network from there. I don’t know what phone you have, so this is just a guess. Also, have you changed anything with your wifi system at all since you installed you other Ring devices?

I have connected camera’s to the same network at the same time and they connected fine. My phone connects to the bridge but when it searches for the wi-fi netwaork it never comes back with anything.

1 Like

That is strange. It’s not your network. It could be your phone… What are you using? Some have settings that will switch to mobile data if it can’t find a wifi connection with the internet.

Its a samsung andriod.

Make sure in your wifi settings that switch to mobile if wifi doesn’t have internet or something like that is disabled before you try the Ring connection.

I switched to my iPad ring app and it connected and to the wi-fi no problem. must be a setting on my andriod phone. I new it shouldn’t be that hard to setup.


Awesome. It’s a setting in wifi. I’ve seen it before. But using another device will get around this too. Glad it’s working.


what’s the app version you are using? is it Android?

I had this issue with the android app. I had to update the application to the latest one available in the play market and the setup worked.

hi im having the same issue… already try 2 ring bridge the same problem. can you provide the steps you do to sort this out. thanks. RING takes time to get through them

I used a Ipad that only had wifi connectivity. The app on my andriod phone would not work to setup the device. but after i set it up it works fine from the andriod app.