Battery charging to green but doorbell still not connecting

Having order two new Ring batteries, neither are any good. One is charging to green but still not allowing the doorbell to connect. The other continually charges to amber and green. This is the second time I’ve ordered new Ring batteries that fail.

Hi @user32312. When charging the battery, you will see the orange and green LEDs lit until the battery is fully charged and only the green LED will be lit. You’ll then need to insert the fully charged battery into your Doorbell and press the setup button underneath the faceplate to put it into setup mode. If you do not see any lights on the Doorbell after doing this, try resetting the Doorbell entirely by holding down the setup button for at least 20 seconds.

If you still can’t complete the setup process in the Ring app after trying these steps, please give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.