Automatically display Ring Camera on Echo Show when motion detected

The temporary solution that flyfish posted works. When the camera detects motion my echo show will display camera but for some reason she always says “OK”. This is driving me nuts. I know its part of the way alexa works by verifying she understands the command but the constant “ok” is grating. In settings there is a way to set alexa in to brief mode. That is where she stops saying “ok” but it does not work with routines.

This is silly that we have to go through these extremes to do what should be natural. My video 3 plus doorbell automatically shows video with movement but not my spot light camera.

My android phone gives me notifications along with a thumbnail photo for any event on both my cameras so I know handling the video is possible.

I think I’m going to return the spot light camera and pick up an arlo camera. That works. Or at the very least swap it for a doorbell camera.

I still can’t find a custom option, I only have Android phones, perhaps it shows on ios

THANK YOU SOOOO MUCH!..It works and I could not be any happier!

1 Like

Thank you so much! I confirm that your solution worked for my Spotlight cameras with my IPhone. Incidentally, I spoke with Amazon customer service and they couldn’t figure this out.

I have not figured out a way to have Alexa stop saying “OK” with Routines… FWIW

Very annoying, especially if you are playing music from your Show. I’ve tried multiple things, seems like a good old fashion BUG…

Many thanks to those responsible single for the links, routines updated perfectly here in the UK with Ring Pro and IOS.

I should imagine the restrictions are in place to increase adoption of subscription models: If motion events are displayed automatically, the desire for a user to review past events (and pay for the privilege) may be limited…

Now if I could only get Echo’s to carry on doing whatever they were before the doorbell event, all would be tickety-boo.

Does anybody know of a command word for this? Wrong forum I know, but it drives me mad. Sometimes ‘Play’ will work, but often it will chose an alternative source, or play a shuffling playlist at the beginning again.

First-world problems!

@flyfish
Thank you!
My fire 8 HD works fine for Ring motion or doorbell pushes when not charging but when charging only doorbell pushes worked.
Downloading your routine gave me custom action in Canada.
It has a big delay but now motion works.

plus one from me… this should be a default option

Thank you so much! This works Fantastic!