All Ring devices Disappeared from my app and online account?

Just noticed today, that all my devices disappeared from my iphone, andriod phone and my online account?

Hey @DW66! That should not be happening, I recommend uninstalling and reinstalling the app as your first step. Please also ensure there is not a second location on your account, or you are no viewing a different location without devices on your account.

If this concern persists, please reach out to our support team, at 800-656-1918, for further assistance. Thank you!

This is currently happening to me! My partner who i added to the device is still on and able to see the camera etc but myself (owner) has lost everything. I’ve reinstalled the app twice! And when I go to set up again it just says “get the owner the add me” “I am the owner!!!

Both ring doorbells disappeared from my app and online account. When I try to reinstall the devices, it says the devices are already registered to an account and won’t allow me to proceed to reinstall them. I deleted the app and reinstalled it, logged out logged back in, tried both via iphone and computer and cannot get any devices back. Nothing changed for this to happen (meaning wifi at home). Not sure what else to troubleshoot at this point.

Hey neighbors! If Marley’s recommendations did not resolve this concern, please give our support team a call at one of the numbers availablehere. They’ll be able to take a closer look at your account and your devices and ensure everything is in order. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. Feel free to report back on what support recommends as it can help other neighbors with a similar concern! :slight_smile:

Did you get it fixed? Mine says the same thing. I need the ‘Owner’ to connect me… And I am the owner… I’ve been trying for 4 hours…

Never had this problem before. My devices disappeared from the iPhone App. I can see previous activity in the online account.

Al my Ring devices disappeared from my iPhone App. I can see previous history online.

After installing the “doorbell”, I had the same problem with all of my previous devices disappearing from under “devices”. I would go to “devices” where I previously saw all my devices listed and none were there, only the doorbells and alarm base station were listed. What I eventually figured out was that if I clicked on the “alarm base station” it would then display all of the devices that previously showed when I clicked “devices”! I only happened upon this after I had reinstalled the app twice and still was not seeing the devices listed.

2 Likes

Thank you for sharing your experience with the Community, @mer1! After taking the steps you shared with us, has everything been working as intended?

1 Like

I’m still having the same issues, it’s been months. And the weird thing is, I still get notifications of motion and doorbell. If I am quick and open through the notification, I can see the camera live and everything. If not, I cannot access the doorbell device at all. Not sure what else to do.

I’m having the same problem. Both doorbells are gone from my online account. I keep getting prompted to “set up devices at my location”.

But they are still working on the App.

When I go to my Plans page, it shows 2 listings for my address. One has no devices. The other listing shows both doorbells. Screenshot attached.

I am having the very same issue. All of a sudden it did not work and all of the cameras are missing and cannot reinstall

Hi neighbors. It sounds like you have multiple Locations in the Ring app. This inadvertently happens sometimes during creation of your Ring account. No worries, you can delete the extra Location without affecting the Location with your existing Ring devices. You can find out more about this by reading this Help Center article.

1 Like

I installed my Ring system yesterday and it was working perfectly. I added a video doorbell today and all of the other devices disappeared from my app except the base station which is now disconnected from my wifi. I called Customer Support and deleted and readded the app with no success. Customer Support then told me to manually add each of the 13 devices all over again. This is so frustrating that this is happening to many people according to this string of notes. I did have duplicate locations on my app even though I only created one AND I can see my old devices in my history which the Customer Support person said she could not. Deleting the duplicate location did not fix the problem. In Mode settings, it appears all of my devices are still there? Has anyone had any success in fixing this without having to readd all of your devices again?

Same has happened to me - all devices and locations gone. PLan gone. Even thought you billed me a few days ago!!!

I found my original devices after you click on the base station device, you will see your keypads, sensors, range extenders, etc.

1 Like

Thank you for posting, looks like a hierarchical design thing that I didn’t realize until I read this.