All End to End encrypted videos 6 seconds long. Indoor Cam

All of my End to End encrypted videos are 6 seconds long no exception (2x ring indoor cams both of them) i have changed the record length setting multiple times and also disabled auto no change. At the end of the videos like the last second its like the rest of the video has been cramed into that second. Having downloaded the clips onto my iphone it reports the videos as being 6 seconds long and will also mess up the last second of the video.

I have reset the devices to factory, after this the non encrypted videos work fine however when i resetup end to end encryption the problem returns. Is anyone else with end to end encryption on indoor cams having this issue ? Or is anyone with non encrypted indoor cams willing to set it up to test if this is a wide spread issue?


This issue started about 2-3 weeks ago ive had the cams with e2e encryption for about a year and with the exception of the now fixed decryption error not ran into any other issues.


user39588 -

You are very lucky if you’ve only been experiencing problems with the End-to-End Encryption feature for 2 to 3 weeks. My Ring Doorbell Pro 2 has been experiencing serious problems for three months – including, but not limited to, the problems that you mentioned.

In addition to the recording length problems, the “clipped/skipped/missing” motion, and the drastically speeded up motion… having you also been experiencing problems with Motion Zones, Privacy Zones, etc.?

At this point, one has to wonder if Ring is attempting to “have its cake and eat it too”. In other words, marketing/advertising the availability of the End-to-End Encryption feature (to sell products)… while tricking customers who use the feature into abandoning its use (so Ring doesn’t have to support it).

1 Like

Hey @Frustrated427 good to see you again LOL. I was the one who started the decryption error post a few months ago.

As for the 6 second video recordings- I can confirm. ALL my end to end encrypted cameras are only recording 6 second videos. Nothing I do on the software side fixes the issue. I’ve spent days and days problem solving and can confirm that rings servers won’t accept E2EE videos longer than 6 seconds.

I believe this is done with pure intent on the end of ring. They don’t want their customers to use the E2EE service. In addition to the decryption errors a few months ago, i still get “video missing” messages in addition to the 6 second in length videos. Until ring decides to fix their issues, we are stuck with 6 second video recordings.

1 Like

@user39588 same exact issues on my end with the E2EE cameras. 6 second videos. I’ve been doing internal testing for weeks and can confirm it is indeed on rings end. We are at their mercy to fix the problem. Let’s hope this post can get some traction.

At this point, using the E2EE features nearly renders the cameras useless. Unfortunate but true.

1 Like

user38894 -

I was hoping you would post in this thread.

I’m surprised you’re only having problems with Video Recording Length and “Video Missing” messages.

My encrypted video clips are a real mess. For example:

  • I’m (intermittently) encountering “Video Missing” messages when attempting to view encrypted video clips.
  • Motion Zones are being ignored (which means that the majority of video clips are created as a result of motion that occurs OUTSIDE a motion zone. There are also problems creating Motion Zones).
  • The Video Recoding Length setting is being ignored (which means that video clips are very short and important action is not captured).
  • Although motion that occurs near the beginning of a video clip appears to be normal… content quickly changes to appear as “snapshots in time”, displayed at a rapid pace (presumably, due to missing video frames). Thus, anything that is moving in real life (such as people, animals, birds, tree branches, flags, vehicles, etc.) seems to mysteriously disappear and reappear somewhere else… at a rapid pace.
1 Like

user38894 -

If the End-to-End Encryption problems weren’t intentional, they presumably would have been fixed as soon as they were reported. After all, one would think it would be very embarrassing for a company to keep “breaking” features that worked in the past.

Of course, the biggest reason that Ring (and its parent company) may want to trick customers into abandoning the End-to-End Encryption feature may be to limit customer privacy. If they truly cared about customer privacy/security, they would ensure that it was truly impossible for ANYONE to access ANY customer video clips, snapshots, camera previews, audio, etc. unless a customer deliberately did something like post them online.

1 Like

Ahh yes. The snapshot in time thing is happening on my end as well with my indoor camera. My outdoor stick up camera only records for 6 seconds, parallel to OP’s complaint. However, like you said, my indoor camera has that weird snapshot in time glitch too. It records the video, but the last 5-10 seconds of that video are just snapshots, effectively missing all motion.

From what I gather (at least on my devices), my wireless battery powered E2EE cameras have no issues. They also didn’t have the decryption error from a few months back. They operate as they should. For whatever reason, Ring’s server + wired E2EE cameras don’t work, which is weird considering the encryption protocol (from what I’ve gathered via their whitepaper) is the same regardless of camera type. So, if you do end up buying another ring camera in the future, stick to a solar powered battery camera over a wired one.

I’ll keep diving into the issue, but my knowledge doesn’t expand beyond their published whitepaper on encryption. It’s just a waiting game until Ring discovers that there is even a problem (as we have seen before, this could take a while).

1 Like

Hi neighbors, thank you for taking the time to share details on what you’re experiencing with your E2EE videos. We’d like to look into this further, but will need to gather some information that we can’t obtain on the Community. Please give our support team a call at one of the numbers available here so we can investigate this further. If you are outside of the US, please visit here to see how to contact support.

1 Like