Alexa Skill Doesn't Honor Motion Schedule

A solution offered by customer support was to use the wedges to aim the camera down more, set the distance to the middle position. Apoarenty its not really a didtance setting but one of object heat. Infrared light. The middle setting sets it for human size objects. Not very small or large like cars. This can help. Also, they had me turn off ALL zones. They said that is diesnt actually turn them completely off but sets it to about 5 feet, resulting in only a human within 5 feet of the door triggering motion. I am setting it.Hopefully this works.

I raised mine and added another wedge so that bottom of stairs is visible. I am now picking up people at desired distance. They still need to enable a global snooze. They also need to bring full functionality to echo show

Changing the wedges, zones, etc. doesn’t work for me. Have people in my house who work different hours. Someone leaving at 5 am doesn’t need to awaken someone who sleeps until 8 am. Someone who may arrive home at midnight awakens someone with an echo dot in their room who has been asleep for 3 hours.

Right now my workaround is to unplug the echo dot at bedtime. Seems stupid, and very disappointing.
Tired and Grumpy.


Oh that would be nightmare. Yes, Alexa device specific monitoring schedule is needed.

1 Like


I haven’t figured out yet how to create start a topic in the Integrations-feature-request board, and I didn’t find it but am fairly certain that the people have already created that topic discussion. So, I will just place my initial comments here for now…

This problem is real. I hope that you understand the need by now. We have lots of echo devices in each of the bedrooms and throughout the house. They are used for alarms and announcemnts. So, setting them to do not disturb is not the answer.

The answer is for Ring’s alexa skill to allow the same functionality as the Ring app uses. Those are a motion schedule and motion snooze. At nighttime I should be able to set a schedule for the alexa devices to be quiet. And like the other user suggested, if I am in the front yard raking leaves and know that someone is in the house, they should not have to continue hearing the motion detected announcement.

Please add this as a priority ticket. Otherwise, the Alexa skill is a large nuisance and that was a big reason for our recent purchase of your product.

By the way, today is January 1st, 2020. We stayed up until midnight last night. The milkman delivered our milk on the front porch at 6am. All of the echo devices announced this…


I thought that I had replied to this post, yet I do not see it here… Hmmm, that’s interesting.

Oh well, I have returned to tell you that I solved the problem. I have not seen anywhere in this discussion the answer. So, I thought that I would share my findings.

The resolution did involve creating an Alexa “Routine”. I simply triggered on a “Motion Detect” from the Ring device. I set the time to be from 10pm - 7pm that the routine would be enabled. The action to be performed was setting “Do Not Disturb” on the devices I listed in the routine, namely the Echo Dots in my kids’ bedrooms. I set the duration to be 30 seconds. This causes the notification to not be heard on these devises and then returns them to their previous state. So, if they have an alarm or we send them an announcement, the Echo Dots will function normally.

Now, if the milkman shows up on the front porch at 6am, he will not wake up the kids!

PS. There is still the matter of recreating the “Motion Snooze” functionality on Alexa. Now that I know a little more about Alexa, I am hoping that I can create commands to take care of that problem. This would be something like raking the leaves in the front yard and not wanting the people in the house to hear continual “Motion Detected” notifications.

It would still be nice if Ring would embed some of this functionality into their Alexa Skill integration. Therefore, each user would not have to recreate these routines and commands. Hopefully you will be able to push out an update with these resolutions soon…


Turning off the Motion alert in Ring, is NOT a solution because it permanently disables Ringing on linked devices like the CHIME.

This is not Solved.!

Dont shut the motion off in the ring app shut it off in the alexa skill. Then make an alexa routine using motion as the trigger. The only issue is you have to make a seperate routine for each alexa device should take you no more then 10 minutes though.

Can you expand on the steps you took? I’m still not sure this solves the request some users are asking for.

Setting up a routine is not really a solution for me. My problem is the Alexa skill does not honor the snooze setting in the ring app and there is no option to tell Alex to set the snooze or to ignore motion for a pre set time.

This becomes an issue when my kids are playing in one of the motion zones during the day. I don’t necessarily want to be alerted by Alex every 5 minutes that they are moving. But this is not something I can define a schedule for so using a rotuine is not an option.


I’m confused. Has the Alexa app changed? If I go to Routines I’m shown existing routines, featured routines, and I’m offered an opportunity to create a new routine (the “+” at the upper right corner). The “devices” button is at the lower right corner, and touching that will take you out of “routines.” So I’ve got two choices (neither of which matches what you’ve said here) - Go to devices and try to set up the Ring camera there (as we know, that doesn’t work), or to create a new routine. Creating a new routine there is no “motion” variable “when this happens.” Going to “Smart Home” offers an opportunity to use the Ring camera, but the only variable available is “not detected” or “detected” - not a schedule. Sure could use some help here. Perhaps this is something that cannot be done. Sure would be nice to have the Ring app integrate fully with Alexa, as do the apps for Nest thermostats and Kasa lighting.

I got so disgusted and embarassed with Alexa shouting out “motion detected” every time neighbors in my apartment building threw out garbage, I disabled motion alerts from Alexa. They still alert on the family’s Apple devices and chimes so it was no big deal.

What finally broke our will in turning it off on Alexa is the well-known propensity for a Ring to greet the dawn with an alert. . . in the master bedroom at 5am. Doesn’t take much of that to convince one this was not such a great idea after all.

I am able to put my ring camera on a schedule in the Alexa app. In the Ring app I have motion detection on and motion alerts off. In the Alexa app I have motion announcements off. In the Alexa app I have a routine called Barn detects motion. In that routine I have it active between 6 a.m. and 10 p.m. if the camera detects motion between 6 a.m. and 10 p.m. it will automatically show on my Echo Show 8 and the only thing she says is okay. During that time my ring camera blinks a blue light. During the night when my camera detects motion it just shows a solid blue light and no notifications. For testing purposes the Echo Show 8 has to be at the home screen and the Alexa app cannot be running on your phone. Also creating a routine called go to home is handy to get your Echo Show 8 back to the home screen. If you want a notification on another device you have to create another routine for that device.

I followed your instructions last night, and finally I had a good sleep without being disturbed by my Alexa downstairs announcing that my husband was leaving the house at 6am. Thank you so much.

I don’t see how creating an Alexa Routine is a solution because it doesn’t prevent Alexa devices from announcing motion alerts when motion detection is snoozed or when geofence or smart alerts are active.

Basically if the app doesn’t show an alert, the Alexa skill shouldn’t either.

Ring is an Amazon company. If Amazon can’t get it’s own devices to work properly with its other devices something is very wrong.

How can this not be solved after over a year and a half? Wonder if Google Home has the same issue?? I own about 14 Alexa devices, from Echo through Echo studio and everything in between. About to chuck them all because this is really a problem and it would appear if it hasn’t been fixed after this long they just don’t care.

Over a year and a half? I’m guessing the team didn’t care? Why can’t the ring skill simply mimic Ring system settings???

1 Like

Hi neighbors! This request has been asked for in our Feature Request board here. Please add your votes and feedback for this request on that thread, as the Feature Request board helps us to organize and share requests with our teams. I will be marking this reply as the solution so that other neighbors who search and find this post can then locate the associated request. :slight_smile: