Alexa Skill Doesn't Honor Motion Schedule

I feel like the workarounds presented here aren’t sufficient. The problem is bigger. The echos should also be honoring the motion snooze. I like to snooze the motion when I’m going to be in the driveway and I know someone is taking a nap in the house. The chime and the Ring app don’t alert but the echos still announce the motion.

6 Likes

Tried this. It doesnt work. This doesnt work since the Alexa devices dont work with this suggested work around. Ring needs to improve this Alexa skill so that we can turn off motion notification during certain hours of the day for those of us with pets. Alexa will sound off motion where our other devices you can set a schedule.

5 Likes

Yeah a routine in Alexa isn’t a good solution because when I’m not home I still want the Ring app to chime - so I don’t want to disable motion alerts in Ring.

4 Likes

I contacted Ring tech support and asked them to submit a ticket about this.

I suggest everyone do the same.

1 Like

If you wish to have this feature, it would be better noted in the Integrations Feature Request board. Thanks

I found this forum looking for solution to this same problem. I was heavily invested in Echo 6 devices in a 4 story house. I added a full Ring alarm system and Doorbell solely based on the integration ability with Echo…only to find that motion alerts are terrorizing my family. I kept telling them “just snooze the doorbell” with your phone app…only to discover that Alexa doesn’t care about Ring’s snooze settings. When I contacted Ring support, I was told I would need to configure each Echo device motion alert separately…which I’ve spent 4 hours pouring through internet posts and Ring/Alexa apps and still haven’t figured out how to configure each Echo device to either turn off or snooze Ring Doorbell 2 motion alerts.

Now that Amazon owns Ring: CAN YOU PLEASE FIX THIS? JUST MAKE THE SNOOZE SETTING GLOBAL TO INCLUDE ECHO DEVICES WOULD BE HUGE

7 Likes

@Jennifer - Ring Community Manager:

So Alexa not honoring Ring settings is a ‘Feature’, and not a Bug?

Please ping the developers on this, it’s a significant problem.

8 Likes

I am sending your feedback directly to the team :slight_smile:

1 Like

I agree 100%. This has been a real pain. I turned it off so Alexa doesn’t go all day. Hopefully they can address this issue.

2 Likes

I’m starting to wonder if the motion schedule is a user specific setting. I started to suspect recently that the motion snooze for the floodlight cam is just for me and not a global thing so even though I don’t get alerts the chime and everyone else’s phone goes nuts.

A solution offered by customer support was to use the wedges to aim the camera down more, set the distance to the middle position. Apoarenty its not really a didtance setting but one of object heat. Infrared light. The middle setting sets it for human size objects. Not very small or large like cars. This can help. Also, they had me turn off ALL zones. They said that is diesnt actually turn them completely off but sets it to about 5 feet, resulting in only a human within 5 feet of the door triggering motion. I am setting it.Hopefully this works.

I raised mine and added another wedge so that bottom of stairs is visible. I am now picking up people at desired distance. They still need to enable a global snooze. They also need to bring full functionality to echo show

Changing the wedges, zones, etc. doesn’t work for me. Have people in my house who work different hours. Someone leaving at 5 am doesn’t need to awaken someone who sleeps until 8 am. Someone who may arrive home at midnight awakens someone with an echo dot in their room who has been asleep for 3 hours.

Right now my workaround is to unplug the echo dot at bedtime. Seems stupid, and very disappointing.
Signed,
Tired and Grumpy.

3 Likes

Oh that would be nightmare. Yes, Alexa device specific monitoring schedule is needed.

1 Like

Jennifer,

I haven’t figured out yet how to create start a topic in the Integrations-feature-request board, and I didn’t find it but am fairly certain that the people have already created that topic discussion. So, I will just place my initial comments here for now…

This problem is real. I hope that you understand the need by now. We have lots of echo devices in each of the bedrooms and throughout the house. They are used for alarms and announcemnts. So, setting them to do not disturb is not the answer.

The answer is for Ring’s alexa skill to allow the same functionality as the Ring app uses. Those are a motion schedule and motion snooze. At nighttime I should be able to set a schedule for the alexa devices to be quiet. And like the other user suggested, if I am in the front yard raking leaves and know that someone is in the house, they should not have to continue hearing the motion detected announcement.

Please add this as a priority ticket. Otherwise, the Alexa skill is a large nuisance and that was a big reason for our recent purchase of your product.

By the way, today is January 1st, 2020. We stayed up until midnight last night. The milkman delivered our milk on the front porch at 6am. All of the echo devices announced this…

6 Likes

I thought that I had replied to this post, yet I do not see it here… Hmmm, that’s interesting.

Oh well, I have returned to tell you that I solved the problem. I have not seen anywhere in this discussion the answer. So, I thought that I would share my findings.

The resolution did involve creating an Alexa “Routine”. I simply triggered on a “Motion Detect” from the Ring device. I set the time to be from 10pm - 7pm that the routine would be enabled. The action to be performed was setting “Do Not Disturb” on the devices I listed in the routine, namely the Echo Dots in my kids’ bedrooms. I set the duration to be 30 seconds. This causes the notification to not be heard on these devises and then returns them to their previous state. So, if they have an alarm or we send them an announcement, the Echo Dots will function normally.

Now, if the milkman shows up on the front porch at 6am, he will not wake up the kids!

PS. There is still the matter of recreating the “Motion Snooze” functionality on Alexa. Now that I know a little more about Alexa, I am hoping that I can create commands to take care of that problem. This would be something like raking the leaves in the front yard and not wanting the people in the house to hear continual “Motion Detected” notifications.

It would still be nice if Ring would embed some of this functionality into their Alexa Skill integration. Therefore, each user would not have to recreate these routines and commands. Hopefully you will be able to push out an update with these resolutions soon…

3 Likes

Turning off the Motion alert in Ring, is NOT a solution because it permanently disables Ringing on linked devices like the CHIME.

This is not Solved.!

Dont shut the motion off in the ring app shut it off in the alexa skill. Then make an alexa routine using motion as the trigger. The only issue is you have to make a seperate routine for each alexa device should take you no more then 10 minutes though.

Can you expand on the steps you took? I’m still not sure this solves the request some users are asking for.

Setting up a routine is not really a solution for me. My problem is the Alexa skill does not honor the snooze setting in the ring app and there is no option to tell Alex to set the snooze or to ignore motion for a pre set time.

This becomes an issue when my kids are playing in one of the motion zones during the day. I don’t necessarily want to be alerted by Alex every 5 minutes that they are moving. But this is not something I can define a schedule for so using a rotuine is not an option.

4 Likes